LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-01-2016, 04:08 AM   #1
iFunction
Member
 
Registered: Nov 2015
Posts: 248

Rep: Reputation: Disabled
.emacs file ignored by Raspberry Pi


Hi there,

does anyone know where the .emacs file is supposed to sit on a Raspberry pi, I have one that I have copied from my Mac and it does work, though only when you start emacs from the start menu or a desktop icon, but then emacs only starts up in read only mode.

I usually start if from the terminal using:
Code:
sudo emacs /file/I/want/to/edit
but then it just opens up as the standard default settings.

How can I get it to open with the .emacs file no matter where it is launched from.

Kind regards
iFunc
 
Old 03-01-2016, 08:01 AM   #2
rtmistler
Moderator
 
Registered: Mar 2011
Location: USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 8,315
Blog Entries: 13

Rep: Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703Reputation: 3703
It's supposed to go in your user account's home directory.

One thing to try also is to use the Options menu and choose Save Options. When that is performed, the status bar at the bottom of the frame should tell you that it saved the .emacs file and also where it saved it at.

Why do you need to do sudo to run emacs though? Consider figuring out why this is so and see if you can resolve that first.
 
1 members found this post helpful.
Old 03-01-2016, 08:29 AM   #3
iFunction
Member
 
Registered: Nov 2015
Posts: 248

Original Poster
Rep: Reputation: Disabled
This is the main problem, on a Raspberry Pi, emacs default has the buffer as read only, so the only way I have found to get around that is to open it using sudo from the command line.

Well it appears that C-x C-q removes the read only flag which is nice, I will try the .emacs file again when I get home.

Thanks for the tip.

Regards
iFunc

Last edited by iFunction; 03-01-2016 at 08:33 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Emacs colour schemes on Raspberry Pi iFunction Linux - Newbie 4 11-25-2015 05:24 AM
emacs::PDE .emacs file question pythonsyntax Linux - Software 1 06-08-2012 01:29 PM
where is the .emacs file in the emacs source code tarball? aizkorri Programming 2 01-13-2007 03:05 PM
emacs not responding to .emacs file in Mandriva 2005 LE. Please help LaptopLinux Mandriva 1 06-08-2005 09:36 AM
edb (emacs database) won't open file - emacs 20 & 21 tip184 Linux - Software 0 04-03-2004 08:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration