LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-15-2008, 08:49 AM   #1
malibec2005
LQ Newbie
 
Registered: Oct 2008
Posts: 16

Rep: Reputation: 0
emacs editing software not worrking


Hi,

emacs was working perfectly. Suddenly when I typed "emacs" the following massage appeared:

Connection lost to X server `localhost:11.0'


Thanks
 
Old 10-15-2008, 03:57 PM   #2
cyent
Member
 
Registered: Aug 2001
Location: ChristChurch New Zealand
Distribution: Ubuntu
Posts: 335

Rep: Reputation: 73
Emacs is working.

There is something odd about your X windows setup. Try run some other X windows program like xterm and you will see what I mean.

Have you used..
* ssh?
* su?
* virtual console?
* vnc

If so that may be your problem.
 
Old 10-15-2008, 04:44 PM   #3
Ryanjon7
Member
 
Registered: Apr 2006
Location: North Vancouver, B.C., Canada
Distribution: Fedora 14
Posts: 38

Rep: Reputation: 15
RE: emacs editing software not working

It seems your display variable is not set correctly. All locahost machines have it set to :0.0 by default. Yours is set to localhost:11.0. This is incorrect.

In a shell type; ( you do not need to be root )

echo $DISPLAY

This will show you what your display is currently set at.

You want to change it to :0.0, to do this type; ( you do not need to be root )

DISPLAY=:0.0

Now type emacs again in the shell and it should work.

In retrospect you can display all variables by typing;

env

Do not change any unless you know exactly what you are doing.
 
Old 10-16-2008, 04:33 AM   #4
malibec2005
LQ Newbie
 
Registered: Oct 2008
Posts: 16

Original Poster
Rep: Reputation: 0
emacs not worrking

Hi,

I did exactly what you said but i have the following massage:
emacs: Cannot connect to X server :0.0.
Check the DISPLAY environment variable or use `-d'.
Also use the `xhost' program to verify that it is set to permit
connections from your machine.

Thanks
 
Old 10-16-2008, 06:49 AM   #5
malibec2005
LQ Newbie
 
Registered: Oct 2008
Posts: 16

Original Poster
Rep: Reputation: 0
Hi,

I Opened Exceed for SSH (passive) before starting the emacs. it works.
but it was worrking before with out this step. can any body tell me why nwo i need to do this step?

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Emacs editing, Pt.5: Shape your Emacs view LXer Syndicated Linux News 0 08-09-2007 08:46 AM
LXer: Emacs editing: Options, registers, and bookmarks LXer Syndicated Linux News 0 07-21-2007 07:01 PM
emacs editing rhtml ? lilili Programming 1 01-27-2007 10:37 PM
Editing Emacs colors? ljr2600 Mandriva 4 09-18-2004 07:50 AM
getting soundcard worrking cblamer Slackware 2 12-18-2003 12:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration