LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   EHLO receiving email problem (https://www.linuxquestions.org/questions/linux-newbie-8/ehlo-receiving-email-problem-643233/)

katkota 05-19-2008 08:41 AM

EHLO receiving email problem
 
Folks;
I'm trying to send/receive e-mail using ehlo, every thing seems fine until i try to receive the e-mail, i don't get it, it just hangs after entering the recipient e-mail address. below is the steps i took & the results:

mi0-nus-r0-report01:~ # telnet 10.128.4.153 25
Trying 10.128.4.153...
Connected to 10.128.4.153.
Escape character is '^]'.
220 NUMEVP04.na.imtn.com Microsoft ESMTP MAIL Service, Version: 6.0.3790.1830 ready at Mon, 19 May 2008 08:39:34 -0400

ehlo domain.com
250-NUMEVP04.na.xxxx.com Hello [10.150.126.105]
250-TURN
250-SIZE
250-ETRN
250-PIPELINING
250-DSN
250-ENHANCEDSTATUSCODES
250-8bitmime
250-BINARYMIME
250-CHUNKING
250-VRFY
250-X-EXPS GSSAPI NTLM LOGIN
250-X-EXPS=LOGIN
250-AUTH GSSAPI NTLM LOGIN
250-AUTH=LOGIN
250-X-LINK2STATE
250-XEXCH50
250 OK

mail from: xxx@xxxx.com
250 2.1.0 xxx@xxxx.com....Sender OK
rcpt to: me@xxxx.com
250 2.1.5 me@xxxx.com

Then it hangs here

Any idea?

blacky_5251 05-19-2008 11:27 PM

How do you mean it "hangs"? Are you just wondering about what to do next?

These are all the commands you need to enter for a simple email test message:-
Code:

ehlo domain.com
mail from: xxx@xxxx.com
rcpt to: me@xxxx.com
data
To: me@xxxx.com
From: xxx@xxxx.com
Subject: Test Message
 
This a test message.
.
quit


katkota 05-20-2008 01:40 PM

Thanks Blacky;
I found the problem, The switch that was needed to allow the e-mail relay wasn't configured properly

Katkota


All times are GMT -5. The time now is 10:04 AM.