LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Edited .bashrc now cannot login as root (https://www.linuxquestions.org/questions/linux-newbie-8/edited-bashrc-now-cannot-login-as-root-4175412030/)

Ajit Gunge 06-18-2012 06:55 AM

Edited .bashrc now cannot login as root
 
Hi All,
I had edited my .bashrc file using the blog http://www.cyberciti.biz/tips/bash-a...inux-unix.html.There is an alias vi=vim.Now when I am trying to edit any file it says vim command not found.Also to install vim when I run the command yum isntall -y vim it says

ajit is not into sudoers file.The incident will be reported.

Now I cannot edit by bashrc file.I cannot edit my sudoers file.Can someone tell me how can I edit my sudoers file.I cannot login as root.How do I get out of the situation.Please help.

pan64 06-18-2012 07:07 AM

you need to remove that alias, or use vi with full path. execute yum as root, not as normal user.





_____________________________________
If someone helps you, or you approve of what's posted, click the "Add to Reputation" button, on the left of the post.
Happy with solution ... mark as SOLVED
(located in the "thread tools")

Ajit Gunge 06-18-2012 08:13 AM

You can always unalias an alais using the command unalias command


All times are GMT -5. The time now is 02:01 PM.