Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-11-2005, 03:56 AM   #1
LQ Newbie
Registered: Feb 2005
Posts: 20

Rep: Reputation: 0
Edit boot options?


im running Redhat9, everything works fine but i have a question:

When my comp is booting, i get this screen where i have to choose which kernel i want to use. There are two entries. One doesnt work correct, so i want to get rid of the entry. How can i do that?
And how can i change the time i have to wait, before it continues booting? It is currently set to 10 secounds, but i want to set it to 3 secs.

Sorry for my bad English :-(

But thanks for your help!
Old 03-11-2005, 04:02 AM   #2
Registered: Jan 2005
Location: Between the chair and the desk
Distribution: Debian Sarge, kernel 2.6.13
Posts: 666

Rep: Reputation: 30
What bootloader are you using? GrUB, LILO?
If it's GrUB, simply delete the entry in /boot/grub/menu.lst (the part from "title" to "boot") and change the value after the "timeout" entry.
Don't know for sure in LILO but it should be similar.
Old 03-11-2005, 04:10 AM   #3
LQ Veteran
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 87
lilo is very similar. Edit the lilo.conf file (in the /etc directory), and remove the section referencing the kernel that you don't want. It may look something like this
image = /boot/kernel-2.6.5
    label = SuSE-2.6.5
    initrd = /boot/initrd-2.6.5
    root = /dev/hda5
    vga = 0x317
    append = "hdc=ide-scsi hde=none hdg=none"
Just delete it. As for the timeout parameter, the value is measured in tenths of a second (eg, 10 seconds = 100). If you want to change it to 3 seconds, change this line "timeout = 100" to "timeout = 30" (no quotes).

Note that in order for your changes to take effect, you need to rerun the lilo program. As root, run
Then reboot to verify that your changes worked. Good luck with it -- J.W.
Old 03-11-2005, 04:22 AM   #4
LQ Newbie
Registered: Feb 2005
Posts: 20

Original Poster
Rep: Reputation: 0
oh sorry, i forgot to mention i have Grub.
But it worked wonderful, thanks both of you for your quick response!
Old 03-11-2005, 04:45 AM   #5
LQ Guru
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
Removing the old kernel will also remove its grub entry. to do this, you would do

$rpm -qa | grep -i kernel
#rpm -e kernel-version

Off course, you will only do this if you know you have no need for the old kernel.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless Keyboard not working to select boot options (Grub boot loader) psrini_vasan Fedora 7 12-16-2009 06:45 PM
Boot options gautcha Linux - Newbie 3 04-06-2005 09:39 AM
What do these boot options do? jalldridge Linux - Newbie 1 03-23-2005 12:18 PM
Using grub to boot.. How do I edit to get mandrake to boot? rrfish72 Linux - General 3 10-29-2004 03:00 AM
Grub boot loader menu shows two linux boot options pramos Linux - Newbie 3 09-13-2004 12:40 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:46 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration