-   Linux - Newbie (
-   -   Easy question: how do I get the mail command to work (postfix) (

blueduck 05-18-2011 07:02 PM

Easy question: how do I get the mail command to work (postfix)
Ok. This is going to seem just downright silly. I'm a little embarrassed to ask it. It's just that the mail command has always just sort of worked on every other system I've used.

This system has postfix installed, which is churning out errors saying "mail transport unavailable" in the mail log. I have a nice SMTP server with a great reputation elsewhere on the internet that I'd like to route all my messages through. Is there an easy way to specify that? It's not really necessary. I'd be happy if I can just get the emails to go out.

bigrigdriver 05-19-2011 03:27 PM is a great research tool for finding solutions to problems in Linux/Unix. Most problems you encounter have probably already been solved and are reported on the internet. For example, searching for "configuring postfix", the first hit I got was how to set up a mail server.

You specific desire to forward all mail to your smtp server would be handled by the "relayhost=" line in /etc/postfix/

You can read more here:

And there is much more to read here:

It times past, google informed users of the existence of specific search filters (linux, microsoft, macos) at the bottom of the Advanced Search page. They no longer do so, and I can't find where that information might be posted. However, the search filters still exist. They filter out 99% and more of non-related hits.

blueduck 06-01-2011 06:33 AM

Still stuck...
I feel like I've tried everything--installing SASL, configuring transport files, etc. All the related threads I've found highlight that it can take days of work to get this working. Just seems like it shouldn't be this hard to send an email.

The latest error suggests that SASL and Postfix are not playing together nicely:
Jun 1 10:04:58 postfix/smtp[21709]: B69E45F974F: to=<>,[]:25, delay=0.09, delays=0/0/0.09/0, dsn=4.7.0, status=deferred (SASL authentication failed; cannot authenticate to server[]: no mechanism available)

I'm happy to post logs, config files, package lists, etc, but before cluttering the thread, I'd just love to ask for advice on next steps:
- does anyone have a sample working configs for Postfix on Fedora? /etc/postfix/, /etc/postfix/sasl_password (pws stripped of course), /etc/postfix/transport, /etc/sysconfig/saslauthd, /use/lib64/sasl2/smtpd.conf, relevant packages (do I need cyrus?), etc

- is there a premium support forum where I can pay someone for their expertise so that I don't spend my next few weekends working through this issue?

Thanks for the help so far. Any additional insights would be much appreciated.

Some of the more helpful resources I reviewed include (all discovered through the great suggestion from bigrigdriver):

All times are GMT -5. The time now is 05:01 PM.