-   Linux - Newbie (
-   -   E: Sub-process /usr/bin/dpkg returned an error code (1) (

Sipps123 12-10-2011 01:57 PM

E: Sub-process /usr/bin/dpkg returned an error code (1)
Get this error whenever I try to install something. Get the same error when I try and remove xrdp. Any tips on how to fix this would be much appreciated.


root@gnarwhale:/home/matt/Desktop/fuse-2.8.6/example/vfsproj# apt-get install dpkg
Reading package lists... Done
Building dependency tree     
Reading state information... Done
dpkg is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up xrdp (0.5.0~20100303cvs-6ubuntu2) ...
groupadd: cannot lock /etc/gshadow; try again later.
adduser: `/usr/sbin/groupadd -g 129 xrdp' returned error code 10. Exiting.
dpkg: error processing xrdp (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Brains 12-10-2011 03:59 PM

You tried to install dpkg which is installed by default during Linux installation and it is the most recent version. But somewhere in the past you did two things that are not complete. One was to either add a user or add a user to a certain group, then when trying to install xrdp it borked because part of the installation requires making user group changes which cannot be done as there are incomplete user group processes lingering.
This article may be the ticket.

Sipps123 12-10-2011 09:43 PM

Thank you for your help brains. I know about dpkg, just needed an example. I read the article that you sent, did the steps, but it was not successful. Some odd behavior I encountered, when I looked for hanging user/group adds I found them, but could not kill them, with the following happening.


root@gnarwhale:/home/matt# ps -ef | grep useradd
root      3969  2427  0 22:39 pts/2    00:00:00 grep --color=auto useradd
root@gnarwhale:/home/matt# ps -ef | grep groupadd
root      3971  2427  0 22:40 pts/2    00:00:00 grep --color=auto groupadd
root@gnarwhale:/home/matt# kill 3971
bash: kill: (3971) - No such process
root@gnarwhale:/home/matt# kill 3969
bash: kill: (3969) - No such process

Any other suggestions? Do you know what the problem is with xrdp?

- Thanks

Brains 12-11-2011 11:11 PM

I'm just going by that article, not experience.

Something I've learned many moons ago was to use an option in the kill command, not sure how it came about but I always use: kill -9 PID, PID being the process.
Have you checked in /etc to see if any of those files exist?
I have a smooth operating Debian and those lock files do not exist, (passwd.lock, group.lock and gshadow.lock). If one or all those files exist, then this is more than likely what you need to do.
I checked and I also have those two processes, useradd and groupadd, they don't show up when I do a: ps -aux, but do show with the ps -ef.

Also, for all three of those files, I have in /etc/ three versions, example:

It is also possible the "cannot lock /etc/gshadow" error arrises due to the file not existing, if so, might be worth trying to create a blank file by that name with command: touch /etc/gshadow

All times are GMT -5. The time now is 09:14 PM.