LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-01-2010, 03:32 PM   #1
kungfur@mone
Member
 
Registered: Jul 2010
Location: California, USA
Distribution: Debian.
Posts: 35

Rep: Reputation: 1
DVD mount problems with KDE4 / UDEV


Hi everyone,

I've been a desktop linux user for several years, but I'm still posting this in the "newbie" section since this is my first post and I'm pretty baffled by this problem.

I'm running Debian Squeeze (i.e. the current Testing release), with a 2.6.32 kernel.

I recently "upgraded" to KDE4 from KDE3, basically because some application or another required some dependencies via APT.

Since then, I've been unable to mount a DVD. The drive itself functions perfectly and I can burn DVDs using K3B. I can't mount a data disc, however.

Here's the dmesg entry for the drive:
[ 4.647809] sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray

Here's my /etc/fstab:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/sda2 / ext3 defaults,noatime,errors=remount-ro 0 0
/dev/sr0 /media/dvd udf,iso9660 user,noauto 0 0
/dev/sda5 none swap sw 0 0
/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/sdb1 /home/chris/usbkey vfat users,noauto,uid=chris,gid=users 0 0
/dev/sda1 /windows ntfs defaults 0 0

Here's what happens when I try to mount a data DVD:
PITFIEND:/etc/udev# mount /dev/sr0
mount: no medium found on /dev/sr0

There is, in fact, valid media in my DVD drive, as witnessed by the fact that it (choke, gag) works fine on my windows partition.

One note: I know next to nothing about Udev. It's possible my rules aren't correct, although if they're not, they were somehow overwritten or eliminated by the "upgrade" to KDE4.

I'd appreciate any advice on this issue. Thanks!
 
Old 07-01-2010, 05:51 PM   #2
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
What happens when you comment out the line in fstab (/dev/sr0), and let hal handle the mounting?
In KDE4, there's a widget (or what have you) that notifies you of removable media insertion. Also, in Dolphin, when removable media is inserted the device will appear in the side menu. Clicking this icon will mount it.

If you haven't messed with the udev rules, they should be correct - not a gaurentee though

Out of curiosity, which optical drive do you have? There are known problems with most Sony Optiarc drives.

Last edited by disturbed1; 07-01-2010 at 05:52 PM.
 
Old 07-02-2010, 12:51 PM   #3
kungfur@mone
Member
 
Registered: Jul 2010
Location: California, USA
Distribution: Debian.
Posts: 35

Original Poster
Rep: Reputation: 1
It is indeed a Sony Optiarc, although it's worked perfectly for well over a year in previous versions of KDE.

In KDE3, just as you describe, DVDs would be auto-mounted and show up in konqueror. In KDE4, USB devices do mount and show up in the sidebar of Dolphin, but optical discs don't.

I just commented out the /dev/sr0 line in /etc/fstab and restarted udev, but there was no change (i.e. nothing happened when I inserted a data DVD.)

I googled like crazy yesterday, but udev still confuses me. Is there a way to check my udev rules for DVDs?

Thanks for the reply, and further suggestions appreciated!
 
Old 07-02-2010, 01:06 PM   #4
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
I personally would not mess with UDEV rules

This is an on going problem with Sony Optiarcs and recent kernel/udev releases. It's a circular finger pointing affair. A 100% fix that I know of, upgrade your optical drive - if possible . The obligatory search for firmware updates should be done as well Link

There's plenty of LKML, bugzilla, and universal distro noise about this problem. Take a look at this Ubuntu bug report to see if it's similar to your experience Link
 
Old 07-02-2010, 01:40 PM   #5
kungfur@mone
Member
 
Registered: Jul 2010
Location: California, USA
Distribution: Debian.
Posts: 35

Original Poster
Rep: Reputation: 1
Thanks for the tips once again.

I'm still pretty sure it's not a hardware issue, however. I installed the entire Gnome desktop just now and had no problem accessing optical media (put in the DVD and, just like that, Gnome opened it.)

This does imply that HAL / UDEV is able to access the drive without going through /etc/fstab, since I still have the DVD entry commented out.

Thus, I'm quite certain the issue is just KDE4. Any further thoughts?

Oh, also, does anyone know what the path is to a mounted dvd? I'm not even sure how to access it via the command line (as you can see, I've got decent technical user chops in some regards, and nonexistent ones in others...)
 
Old 07-02-2010, 02:17 PM   #6
mryuck
Member
 
Registered: Feb 2010
Posts: 107

Rep: Reputation: 23
The path to the mounted dvd is what is in your fstab.
/media/dvd.

You can mount it to another directory with mount /dev/sr0 /another_directory.

Mounting the dvd manually in a terminal should not have anything to do with the desktop you're using.
If the mount command works in gnome it should work in kde or xfce or whatever.
When you have the line commented out in fstab to use hal is when the desktop makes a difference.
 
Old 07-02-2010, 06:41 PM   #7
kungfur@mone
Member
 
Registered: Jul 2010
Location: California, USA
Distribution: Debian.
Posts: 35

Original Poster
Rep: Reputation: 1
Ok...kind of fixed this problem. I'll post the (kludgey) solution here in case anyone else runs into something similar. Basically, there was no .rules file for either of my optical drives in /etc/udev (for *some* reason), so I manually added one, then used a few utilities to figure out where everything was pointing.

I added a file to /etc/udev/:
touch dvd.rules

Here's the entry:
SUBSYSTEM=="block", KERNEL=="hda", SYMLINK+="dvd", GROUP="cdrom"

/etc/init.d/udev restart

I ran the Gnome Disk Utility. It verified that it could see the DVD-ROM. I clicked "mount" from there and it mounted it to /media/cdrom0 (I still don't know what configuration file is pointing to that instead of /media/dvd.)

I can now go through Dolphin and get at /media/cdrom0 and access the DVD.

What still does *not* happen is any kind of mount option in KDE when I insert the disc. IMHO, this is a blunder on the KDE developer's part, in removing some very basic and user-friendly functionality. According to what I read in KDE forums, the official excuse for removing automounting is that different users on the same session would somehow trip each other up if they left USB devices mounted. That scenario probably applies to about 5% of end users at the desktop level, while convenient automounting applies to the other 95%.

But, despite my belly-aching, it works now!

Thanks for the feedback on my earlier posts.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
udev rules to mount external hard drive at mount point akamikeym Gentoo 3 03-31-2010 02:12 PM
Mandriva CD/DVD mount problems eddiep Linux - Hardware 2 03-23-2006 02:58 PM
permission problems with udev: can't access dvd schatoor Linux - General 1 02-08-2006 06:40 PM
DVD Mount problems on MDK 10.1 Community dolphans1 Mandriva 2 09-24-2004 12:10 AM
DVD mount problems w/Debian asphyxiant Linux - Hardware 6 09-17-2003 12:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration