LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   DVD and Recorder not working... (https://www.linuxquestions.org/questions/linux-newbie-8/dvd-and-recorder-not-working-187448/)

selassie irie 05-29-2004 06:45 PM

DVD and Recorder not working...
 
I am very new to linux, and I can no longer play any type of compact disc. I was messing around as root the other evening (BAD IDEA for newbies!!) to try to make Xcd Roast working, and somehow (and I honestly don't know how) I did quite the opposite. I made my cd players unrecognizable or something.

As I said, I'm very new to Linux, so if ANYONE can be patient with me and take me through a step-by-step process on how to possibly fix this major problem, I'd be SOOOOO appreciative!

Thanks a bunch!
selassie irie

Rico16135 05-30-2004 09:45 PM

I'm not too familiar with suse 8.0, but is the OS still mounting your drives? Or is the problem media playback or retrieval? You check your fstab?

Post the contents of /etc/fstab if you they are not being mounted.

selassie irie 05-31-2004 02:45 PM

Okay... well, my cd drives do not mount. I get these error messages for my cd-r and dvd:

Could not mount device.
The reported error was:
/dev/scd0: Input/output error
mount: I could not determine the filesystem type, and none was specified

Could not mount device.
The reported error was:
mount: /dev/sr1: unknown device

I'm guessing that maybe the problem lies in a sym link or something. But I don't know how to go about checking or correcting that.


Fstab looks like this:


/dev/hda5 / reiserfs defaults 1 2
devpts /dev/pts devpts defaults 0 0
/dev/scd0 /media/cdrecorder auto ro,noauto,user,exec 0 0
#/dev/scd0 /mnt/cdrom1 iso9660 user,ro,noauto 0 0
/dev/scd0 /media/cdrom auto ro,noauto,user,exec 0 0
/dev/sr1 /media/dvd auto ro,noauto,user,exec 0 0
/dev/fd0 /media/floppy auto noauto,user,sync 0 0
usbdevfs /proc/bus/usb usbdevfs noauto 0 0
proc /proc proc defaults 0 0
/dev/hdb5 /windows/1 vfat user 0 0
/dev/hdb6 /windows/2 vfat user 0 0
/dev/hdb7 /windows/3 vfat user 0 0
/dev/hda1 /windows/C vfat user 0 0
/dev/hda6 swap swap pri=42 0 0

Maybe this will help?!
Thanks!

Rico16135 06-01-2004 12:10 AM

In Yast under hardware --> cdrom drives is it posting the correct drives? Any of them, all of them? If there are cdrom devices listed try adding them if its able to be selected.

The only thing I'm seeing that could pose an issue is three entries for scd0, with one commented out.

selassie irie 06-02-2004 05:39 PM

well,
for the DVD YaST gives the device name /dev/hdc and for the cd-rw it gives /dev/sr0.
How come the dvd uses hdX and cdrw uses srX?? I guess I will try changing my fstab (but i will not go overboard this time! i learned my lesson!!)

Just trying to learn at least one new thing everyday :)

Looking_Lost 06-02-2004 07:06 PM

'Cos your cdwriter is using the scsi emulation module

selassie irie 06-02-2004 09:53 PM

'nother question...
 
Okay, I use SuSE 8.0.

When I check out my files through the terminal window, sometimes some of them are red, sometimes, green, sometimes yellow, and sometimes there's a star next to the file. What do the different colored text mean and what's the star all about??

Thanks!

PS: Still MAJORLY confused about the cd rom issues. The more help with that, the happier I will beeee!!

t3___ 06-02-2004 09:55 PM

is it just a bad disk in the drive???

selassie irie 06-02-2004 10:00 PM

nope. i've tried ALLLL kinds of differend media discs and music discs in both drives. it's not the disc. it's something much deeper :P ack! :mad:

selassie irie 06-03-2004 04:21 PM

Okay, it's a sym link thing, i have kinda figured it out...

/dev/cdrecorder is linked to /dev/sr1

but it should be linking to /dev/scd0

How do I create that sym link????

When I do..
# ln -s /dev/cdrecorder /dev/scd0
I get....
ln: `/dev/scd0': File exists

Any suggestions or ideas????

Looking_Lost 06-03-2004 06:34 PM

You've got it back to front

And you'll have to del your current cdrecorder link

rm /dev/cdrecorder

ln -s /dev/scd0 /dev/cdrecorder

selassie irie 06-03-2004 08:33 PM

Yippie! All problems solved! Life is gooood :D


All times are GMT -5. The time now is 10:17 AM.