LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   dual port HBA showing two different node_name for both port, why ?? (https://www.linuxquestions.org/questions/linux-newbie-8/dual-port-hba-showing-two-different-node_name-for-both-port-why-941129/)

em31amit 04-22-2012 10:21 AM

dual port HBA showing two different node_name for both port, why ??
 
Hi folks,

I have dual-port HBA in linux rhel 5, that is showing me two different WWNN for both WWPN, technically i have read that every dual port HBA have one WWNN and two WWPN. what could be the reason ? why it is showing me like this. not even on single server but on many of them. ?

MensaWater 04-24-2012 08:24 AM

The WWPN is for each port.

The WWNN is for each node.

While it is valid to have every port on a given node be the same WWNN it is not required. I'm used to seeing separate WWNN and WWPN for each port on Qlogic HBAs. You don't say what HBA you're talking about.

em31amit 04-24-2012 10:24 AM

I am also using qlogic hba card on servers.

So seeing separate WWNNand WWPNfor each port on QlogicHBAs... What's the reason .. how can I configure those ? I usually check node name and port name from sysfs filesystem.

Didn't find any doc for the rhel.

Do explain it more, why it is like this ?

MensaWater 04-24-2012 12:00 PM

I don't think you can configure it but you can change the alias for the ports using scli (Qlogic's command line utility). Not sure if that alias would show up in /sys though as I don't change it here.


All times are GMT -5. The time now is 05:03 AM.