Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 02-01-2006, 12:04 PM   #1
LQ Newbie
Registered: Feb 2006
Posts: 1

Rep: Reputation: 0
Question dual monitors

As a newbie I would like to ask if (and how) I can simply edit my XF86config file in order to enable the use of dual monitors. (Or is there more to it than that?)

I am running RHEL v3.0 and using an Nvidia Quadro graphics card which has both a digital and an analogue outputs which I would like to use.

The current XF86config file looks like:

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell E172FP"
HorizSync 31.0 - 80.0
VertRefresh 56.0 - 76.0
Option "dpms"

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA Quadro FX (generic)"
VideoRam 131072

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"

Section "DRI"
Group 0
Mode 0666
Old 02-01-2006, 03:56 PM   #2
Registered: Apr 2005
Distribution: Fedora Core (latest version)
Posts: 156

Rep: Reputation: 30
Section "Device"
Identifier "Videocard0"
Driver "nvidia" ###make sure to install nvidia driver not generic nv driver
VendorName "Videocard vendor"
Option "TwinView" "yes"
Option "MetaModes" "1024x768,1024x768;800x600,800x600"
Option "ConnectedMonitor" "CRT-0, CRT-1"
Option "TwinViewOrientation" "CRT-0 LeftOf CRT-1"

Make sure to install the nvidia driver from a repo or from Nvidia. Then use the nvidia driver instead of the nv driver. Nvidia uses something called TwinView instead of Xinerama. All I do to add my second monitor is add the previous to my xorg.conf file.
Old 02-01-2006, 03:56 PM   #3
Registered: Apr 2005
Distribution: Fedora Core (latest version)
Posts: 156

Rep: Reputation: 30
For some reason when I clicked the "Post quick reply" button, 2 identical posts were replied. Not being able to delete this second post, I write this.

Last edited by accessrichard; 02-01-2006 at 04:12 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
dual monitors on dual vido cards Spaz17 Linux - Hardware 7 05-04-2006 07:59 AM
Setting up Dual Monitors on GeForce 6600GT dual DVI card. monkiidansu Linux - Hardware 1 09-29-2005 02:21 PM
Dual Monitors -Need Help computergee Ubuntu 13 08-27-2005 05:06 PM
dual monitors, dual video cards, 1 X, 1 text 333333338 Linux - Hardware 0 04-17-2005 04:21 AM
Dual Monitors sykkn Linux - General 2 04-21-2001 10:48 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:47 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration