LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-14-2004, 12:19 PM   #1
Multra
LQ Newbie
 
Registered: Aug 2004
Distribution: OpenSuse 11
Posts: 13

Rep: Reputation: 0
Dual booting winxp/suse


I have a box with xp and suse installed on it and the xp portion will not boot up. I am using the grub boot loader and when i select windows all i get is the 3 commands that are running and a blinking '_'. I want to continue to use the grub or lilo boot loader if possbile. here is my Menu.lst file:


# Modified by YaST2. Last modification on Sat Aug 14 15:53:33 2004


color white/blue black/light-gray
default 0
timeout 8
gfxmenu (hd0,2)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title Linux
kernel (hd0,2)/boot/vmlinuz root=/dev/hda3 vga=0x31a splash=silent desktop resume=/dev/hda2 showopts
initrd (hd0,2)/boot/initrd

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
root (hd0,0)
chainloader +1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
root (fd0)
chainloader +1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe
kernel (hd0,2)/boot/vmlinuz root=/dev/hda3 showopts ide=nodma apm=off acpi=off vga=normal noresume nosmp noapic maxcpus=0 3
initrd (hd0,2)/boot/initrd



Here is my grub.conf file:

root (hd0,2)
install --stage2=/boot/grub/stage2 /boot/grub/stage1 d (hd0) /boot/grub/stage2 0x8000 (hd0,2)/boot/grub/menu.lst
quit


And here is the sfdisk -ls command output:

/dev/hda: 58633344

Disk /dev/hda: 116336 cylinders, 16 heads, 63 sectors/track
Units = cylinders of 516096 bytes, blocks of 1024 bytes, counting from 0

Device Boot Start End #cyls #blocks Id System
/dev/hda1 * 0+ 75177- 75178- 37889271 c W95 FAT32 (LBA)
/dev/hda2 75178 77225 2048 1032192 82 Linux swap
/dev/hda3 77226 116335 39110 19711440 83 Linux
/dev/hda4 0 - 0 0 0 Empty
total: 58633344 blocks


I have read the other forum posts for this problem but the solutions havent helped =(. Any help is much appreciated.
 
Old 08-14-2004, 12:21 PM   #2
hw-tph
Senior Member
 
Registered: Sep 2003
Location: Sweden
Distribution: Debian
Posts: 3,032

Rep: Reputation: 58
Try changing this:
Code:
title Windows
root (hd0,0)
chainloader +1
...to this:
Code:
title Windows
root (hd0,0)
makeactive
chainloader +1
Håkan
 
Old 08-14-2004, 01:33 PM   #3
Multra
LQ Newbie
 
Registered: Aug 2004
Distribution: OpenSuse 11
Posts: 13

Original Poster
Rep: Reputation: 0
Nope that didnt work =/ when i select the windows boot it now says makeactive on it along with the 2 other commands.
If it helps any i am able to see my windows partition on the / directory.

Another problem popped up =). I did the online update and now my CD rom drive randomly pops open. Anyone run into this problem and know the solution?

Last edited by Multra; 08-14-2004 at 01:37 PM.
 
Old 08-14-2004, 02:43 PM   #4
bruno buys
Senior Member
 
Registered: Sep 2003
Location: Rio
Distribution: Debian
Posts: 1,509

Rep: Reputation: 46
Maybe this post can help you:
http://www.linuxquestions.org/questi...918#post937918

Also, look at suse website. There are issues running grub to boot a xp-suse machine.
 
Old 08-14-2004, 05:17 PM   #5
Multra
LQ Newbie
 
Registered: Aug 2004
Distribution: OpenSuse 11
Posts: 13

Original Poster
Rep: Reputation: 0
Do you have a link to where the article is at on the suse website i couldnt find it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual boot WinXP/Debian, grub error booting WinXP ChemBot Linux - General 5 02-22-2007 05:13 PM
Dual-booting MEPIS and WinXP, I want Grub to default to WinXP jjf Linux - Newbie 8 01-19-2006 04:27 AM
dual booting with winxp on two harddrives Virp00 Fedora 5 06-05-2005 11:22 AM
Dual Booting WinXP/SUSE 9.2pro? ronlon Linux - Newbie 13 01-29-2005 06:16 PM
Dual Booting WinXP and Suse 9.1 gazzerh Linux - General 4 07-12-2004 10:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration