-   Linux - Newbie (
-   -   Dual booting SuSe 9.1 and Windows XP (

Bannor 10-04-2004 06:56 AM

Dual booting SuSe 9.1 and Windows XP
I decided to try a Linux installation on my PC at the weekend so I borrowed a friend's SuSe 9.1 Pro DVD. The installation gave a message about Kernel 2.6 not supporting SoftRaid which wasn't going to be a problem because I only wanted to install SuSe on the ide drive anyway.

The installation went okay but I'm unable to get dual booting to work.

PC Specs:
AMD Athlon 3200 XP
ABIT NF7-S v2.0
1024MB RAM
2 x 160GB SATA HDs (RAID 0) - Windows XP
1 x 250GB IDE HD - SuSe 9.1 Pro and storage

Configuration files:
(hd0) /dev/hda
(hd1) /dev/hde
(hd2) /dev/hdg
(fd0) /dev/fd0

/dev/hda10 / ext3 acl,user_xattr 1 1
/dev/hda2 /boot ext2 acl,user_xattr 1 2
/dev/hde1 /data1 auto noauto,user 0 0
/dev/hda9 /tmp ext3 acl,user_xattr 1 2
/dev/hda5 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda6 /windows/D ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda7 /windows/E ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hda8 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrecorder /media/cdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvdrecorder /media/dvdrecorder subfs fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs fs=floppyfss,procuid,nodev,nosuid,sync 0 0

# Modified by YaST2. Last modification on Sat Oct 2 12:40:57 2004

color white/blue black/light-gray
default 0
timeout 8

###Don't change this comment - YaST2 identifier: Original name: linux###
title Linux
kernel (hd0,1)/vmlinuz root=/dev/hda10 vga=0x31a splash=silent desktop resume=/dev/hda8 showopts
initrd (hd0,1)/initrd

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
root (fd0)
chainloader +1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe
kernel (hd0,1)/vmlinuz root=/dev/hda10 showopts ide=nodma apm=off acpi=off vga=normal noresume nosmp noapic maxcpus=0 3
initrd (hd0,1)/initrd

title Windows
root (hd1,0)
chainloader +1

GRUB is installed in the MBR of the IDE drive (/dev/hda) so I changed the BIOS boot order from CDROM,SATA,HD0 to HD0,SATA,CDROM. This allowed Linux to boot via GRUB. However I couldn't boot Windows because GRUB hadn't any reference to the SATA drives so I edited menu.lst and added my own Windows section and tried rebooting. Choosing the Windows option does nothing - GRUB appears to just sit there!

Being a firm believer that there is more than one way to skin a cat, I went and searched the web for a way to boot the Linux installation from NTLDR and found GRLDR (Google:GNU GRUB for DOS). I restored the boot order in the BIOS so that I could once again boot windows and installed the GRLDR file to the root of the C: drive and updated the boot.ini file: C:\GRLDR="SuSe 9.1" and rebooted. Choosing the SuSe boot option booted GRUB, but selecting Linux gave an error message about not being able to load the kernel or something to that effect.

I'm a Linux newbie but I'm quite familiar with dabbling with the PC. I'm guessing that the reason that the GRLDR method isn't working is because the SATA drives have become hd0 and hd1 since I changed the boot order so I need to change the configuration files to reflect this and point hd2 at /dev/hda. Is this just simply a case of updating and menu.lst files?

If possible I'd like to get the first method working as well. Any help would be much appreciated.

aus9 10-04-2004 08:04 AM

as I read it you are using ABSOLUTE pathways instead of relative pathways.

My tutorial recommends you use the root command so I will answer that way.

title linux
root (hd0,1)
kernel /boot/vmlinuz root=/dev/hda10 and junk the rest for the moment
initrd /boot/initrd.img

##### the main change other than no (hd) entry on each line is that you point to /boot then vmlinuz ok?
your initrd file is likely to end in a img or a gz change to suit.

see my troubleshooting guide to see what files you have when you set root as (hd0,1) and then type kernel and then press the tab key if you are unsure what your initial ram disk file is called.

(2) linux has many ways of doing things but I have not learnt the grldr way

3) your windows entry could be if device map file is left as hd0 linux hd1 SATA

title windows
rootnoverify (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1

we have to use the map command to hide the first drive as windows likes to thinks its always first, but we know better wink wink

4) there is no reason why you can not have a different device map file but I recommend you stay with the normal way as its easy to understand. If you want to try a different one remember that if grub is to be your primary bootloader it is NOT going to be in your first mbr once you change to SATA. so you have to re-run grub and change the guilty to suit.

(hd0) /dev/hde
(hd1) /dev/hdg
(hd2) /dev/hda

Then when you issue commands su then your root password then grub
root (hd2,1)
setup (hd0)

will put grub onto sata 1 mbr.

5) the only thing I am not sure about is why you have not tried to mount your satas in your /etc/fstab cos it is not clear if I have your windows setup correct without confirmation. But you can always post back eh?

aus9 10-04-2004 08:09 AM

the longer version of windows would be

title windows
rootnoverify (hd1,0)
hide (hd0,0)
unhide (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1

Bannor 10-04-2004 08:33 AM

Thanks for the reply. I'll try it out later and let you know how I get on.

The reason I haven't mounted the SATA drives is because I don't trust the Linux install not to mess up the drives. During the installation before partitioning the drives there was a message that the SoftRaid configuration was not compatible with the 2.6.x kernel. The suggested partitioning of the install program was something like creating a 50mb /boot partition on /dev/hde, a 1024mb swap partition on /hdg and making the remainder of /hdg one giant partition for /. The installer obviously want to wipe my raid configuration so I'm keeping the new os away from it.

aus9 10-05-2004 09:07 AM

2 corrections
1) back up b4 trying I should have said so earlier if you are concerned see my signature heh heh

2) if you do make sata differnet in your device map file
a) change your bios to suit
b) if on trying out grub your response for root does not equate to what you think your linux should be you need to force grub to read the device map file b4 going into command mode.

grub --device-map=/boot/grub/ (or any filename you chose)

c) you can get away with the first preferred system with no file as grub likes to go from ide to scsi or sata and its not all that hard to run thru a few options but I repeat as soon as you want sata b4 ide you must have a file to help grub out......its a real simple program.

All times are GMT -5. The time now is 06:03 AM.