LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   dual booting (https://www.linuxquestions.org/questions/linux-newbie-8/dual-booting-34478/)

DVation 11-03-2002 08:39 AM

dual booting
 
im tryin to get winxp and slackware to co-exist peacefully...its not working out that way so far. i have xp on my c: drive, ntfs, actually a raid-0 config. i have a 60gb F: and G: drive. on the end of the G: drive i have a 1gb linux swap and a 4gb ext3 partition, on which slack has been sucessfully installed. lilo was put on the superblock so i could use ntldr to boot between xp and slack. in slack i grabbed the boot sector with...
dd if=/dev/hdd6 of=/bootsect.lnx bs=512 count=1
i did run df to make sure that hdd6 was right. i copied bootsect.lnx to C:\ in windows and added...
C:\BOOTSECT.LNX="Slackware Linux"
to my boot.ini ... now whenever I try to boot into linux using ntldr rows of "40 40 40 40" go all across the screen. I've tried this over a few ways and it doesnt seem to work. the only way i can seem to get into linux is with the linux bootdisk i made during install time. anyone have any ideas?

btw the reason im using ntldr is i was afriad of lilo taking over the mbr, i didnt want xp to freak and not let me in, also since im new to linux i was unsure how lilo would handle the raid controllers on which xp lies.

linda 11-03-2002 09:44 AM

You sure don't sound like a newbie to me!

I just installed Mandrake on my WXP computer. I too, wanted to keep my NTLoader intact, but I did install Lilo to the Mandrake partition. I used the instructions below, and it went off without any problems whatsoever. You may want to check through these, and see if you did everything the author wrote. It worked for me!
http://www.littlewhitedog.com/reviews_other_00011.asp

DVation 11-03-2002 12:06 PM

i suppose i could install lilo to the mbr as a last resort, i really would like to hear more suggestions as to how to get ntldr to work properly first however, thank you for your reply

acid_kewpie 11-03-2002 12:43 PM

what does your lilo.conf file say? it's most likely to be a geometry issue, do you have the lba32 option in the file?

DVation 11-04-2002 09:10 AM

i removed some commented lines to save space...here it is...if you can tell me anything about it, or if something is wrong i'd appreciate it. thing is, linux boots fine from a floppy, just not with ntldr...


# Start LILO global section
boot = /dev/hdd6
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x32k
vga = 790
# End LILO global section
# DOS bootable partition config begins
other = /dev/hdg1
label = DOS
table = /dev/hdg
# DOS bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hdd6
label = Linux
read-only
# Linux bootable partition config ends
# OS/2 bootable partition config begins
other = /dev/hdg1
label = OS2
table = /dev/hdg
loader = /boot/os2_d.b
# map-drive = 0x80
# to = 0x81
# map-drive = 0x81
# to = 0x80
# OS/2 bootable partition config ends

acid_kewpie 11-04-2002 09:22 AM

try adding the lba32 option in that # Start... section

lilo will not be involved in a floppy boot, so i'm pretty sure that this is where your problem is.

DVation 11-04-2002 11:20 AM

you will have to fogive me, i am rather new to linux, could you please tell me the line you think i should add?


All times are GMT -5. The time now is 06:51 AM.