LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Dual boot, XP works Fedora goes to command line. (https://www.linuxquestions.org/questions/linux-newbie-8/dual-boot-xp-works-fedora-goes-to-command-line-543253/)

Just Jon 04-04-2007 08:51 AM

Dual boot, XP works Fedora goes to command line.
 
Hello. I'm a stuck newbie, and confused.

I have just installed Fedora Core 6 to dual boot with XP.

After the Fedora install, It rebooted, and Fedora loaded into the Gnome desktop. I had a little look round the installed apps, then shutdown.

Upon rebooting, I chose to boot XP as I needed to get files and a copy of a (reliable!) guide to install my Speedtouch modem. I got the files, copied to my flash drive, and restarted to get back into Fedora to do the modem and get updates etc.

However, this time round, I didn't get the graphical login screen and got a command line screen.

Not sure if you want this but this is what I get on screen:

Fedora Core release 6 (Zod)
Kernal 2.6.18-1.2798.fc6 on an i686

local host login:_ (entered name)
password:_ (entered password)

Last login: (todays date and time) on tty1
[jon@localhost~]$_

I've tried several times, with the same results. XP still works (I'm on the same rig).

If any more info is required, I'll try to obtain it!

Centinul 04-04-2007 08:56 AM

Can you post the output of:

/var/log/messages
/var/log/Xorg.log (I think that is what it's called)

Also please post your grub / lilo configuration.

These may give us some insight to the issue.

Just Jon 04-04-2007 09:07 AM

Certainly, if you can tell me how. Can't read Linux partitions in XP (thank god!)

I have a flash drive I can mount is this the command to mount it?

dmesg | tail (to get the device name)
mount /dev/<device name> /mnt (to mount)

Sorry about the questions...

I'll then need to copy the log files to the flash drive? If so how do I do that, and post my grub / lilo configuration?

Thanks.

timmeke 04-04-2007 09:36 AM

Did you notice any error messages or services failing when booting Fedora (click on the "details" button to find out).

Check also that in /etc/inittab file, the default runlevel is set to 5, not 3.

From the commandline, can you start your X server using the "startx" or "telinit 5" commands?
If not, any error messages?

Any error messages in /var/log/ files, especially the Xorg log already mentionned?

If your Win is on a FAT32 partition (or if you have one defined), you can use that partition to share files between windows & linux.

Just Jon 04-04-2007 11:12 AM

Would you believe it, I got in! It just loaded without issue, or user input. Every thing I own is temperamental :rolleyes:

The only error I saw was about network, but I connect to the Internet through the dreaded Speedtouch 330.

Have issues now though, with modem. Fedora stops loading with an error loading the network ppp0. As I have been trying to get the modem to work, I'm not surprised.

I can get to the Gnome desktop though, so maybe I'll get it working? Here's hoping :study:

Thanks for the help guys, regardless. Much appreciated,

JJ.

timmeke 04-05-2007 02:39 AM

If startx or telinit 5 indeed worked fine and loaded your Gnome desktop environment, then you should look at
the /etc/inittab file.
Look at the line that says something like
id:n:initdefault:
"n" should in your case be 5, not 3. Correct it if necessary.


All times are GMT -5. The time now is 09:55 AM.