-   Linux - Newbie (
-   -   Dual Boot windows messed up partition table and bootloader (

Abraxis 04-26-2009 04:10 PM

Dual Boot windows messed up partition table and bootloader
Okay, So I was previously running my system with Ubuntu 64bit as my primary OS, and dual booted to windows for running some games I couldn't get to work on linux.

The partition table looked like this

/dev/sda1..............7gb.......Linux swap / solaris
/dev/sda2......*.......200mb.....Linux (ext3)
/dev/sda3 .............170gb.....Linux (ext3)
/dev/sda4..............60gb......NTFS (windows partition)

(all primary)

I got a copy of windows xp pro 64bit to upgrade the crappy 32bit. So I go to install it, delete the NTFS partition via the windows xp installation screen. Select the unalocated space and try to make a clean partition in it. I get a message saying I can't format the space because the harddrive has the max number of partitions.

So I figure windows is just a big piece of crap and decide to go back to linux to setup the partition table with fdisk. I exit the installation and reboot. Now it won't boot to linux, it tells me to insert a system disk.

So I'm guessed windows had hijacked the bootloader or whatever when I installed it and that got deleted with the 4th windows partition. I threw in knoppix and added a bootflag to the second partition (the original linux boot partition). That didn't solve anything.

So I figured, whatever, I'll just make the new partition from knoppix, install windows in it and hope windows sorts out the bootloader issue.
Now looking at the partition table in fdisk, I notice something funny. the first three linux partitions show up, but the "start" "end" points seem all messed up. The first partition on the list now starts at 7701 (cylinder?). So it looks like the unpartitioned space is now before the partitions, where it used to be after, is it even possible for them to change??

Anyways, I made an NTFS partition in the free space with fdisk (get a message that disks are out of order; see an option in expert menu to fix order, but I'll leave that till you all educate me a little more). Reboot with windows cd, but it still doesn't like the partition (Windows fault tolerance).

So now I'm stumped, I copied all my files onto my external drive, but I don't want to just wipe the hard-drive and start over. If I could just figure out how to get the system to boot up with linux; whether that means repairing the old boot thing or simply enabling it somehow I have no idea, and why windows setup seems to think 4 primary partitions would be too many. Or if any of you notice some big error in logic with my actions or assumptions that would help to..

If you need more info ask and i'll tell

eltorodeoro 04-26-2009 05:22 PM

Windows does that...
try "SuperGRUBDisk." it's helped me out once or twice. can't give you specifics, but there are some pretty good tutorials out there on how to use it.

good luck!

custangro 04-26-2009 05:27 PM

Here is something that helped me when I ran into a similar problem...

Basically...boot into a live cd (doesn't matter which one) and do...


grub-install /dev/hda
OR if you have a SATA drive...


grub-install /dev/sda
But do yourself a favor and learn to use the grub commands...because this will come up me...I speak from experience ;)


syg00 04-26-2009 05:45 PM

Let's see the output from "fdisk -l" (from Knoppix terminal)

All times are GMT -5. The time now is 11:08 PM.