-   Linux - Newbie (
-   -   Dual Boot problem with 32-bit vist a and 64-bit Fedora 10 (

Ranti 03-28-2009 10:17 PM

Dual Boot problem with 32-bit vist a and 64-bit Fedora 10

I was using 32-bit windows vista and yesterday tried to install the 64-bit fedora 10. but the problem is after installing fedora 10, I cannot boot into vista. it comes up with a msg BOOTMGR missing....Press Ctrl+alt+del to restart. After researching on the internet how to recover from this issue, I have successfully recovered vista but now the problem is there is no grub boot loader or anything now it just boots to vista, doesnt show me any option.

So what is the solution for this problem? should i install a third party boot loader ?? can you suggest any thirdparty boot loader that would solve my problem and would be able to boot vista and fedora?

thanks in advance. I would really appreciate your suggestion.


syg00 03-28-2009 10:36 PM

Sounds like Anaconda (the Fedora installer) merely guessed the wrong partition for Vista. Grub is booting that combination (amongst others) on this very laptop. Would have been easier to fix grub then.
You should be able to boot the Fedora disk and select to boot into your disk system and re-install grub to the MBR.

You can also use the Vista loader to boot Fedora, but you'll need to re-install grub anyway for that to work.

saagar 03-28-2009 10:59 PM

Mr.syg00, cud u pls explain what happens to the vista loader when grub is loaded in mbr. if vista loader is to be placed in some other place, how windows will find out the location of the vista loader when it is booting.? when booting windows, the bios will search for bootloader in mbr, if it is not there, how will it function...? thanks.

syg00 03-29-2009 12:42 AM

@Ranti, just boot the first CD, and select your installed system. Then from a terminal try

su -c "grub-install /dev/sda"
/dev/sda should be correct for you. You will still have the issue with Vista - post the output from these, and we'll see if we can fix that too.

su -c "/sbin/fdisk -l
cat /boot/grub/manu.lst

@saagar; to use the Vista loader, you install grub to a partition (root or /boot usually) and update the BCD data to add Linux as a boot option. I use EasyBCD.

alan_ri 03-29-2009 01:57 AM

syg00,there are some typo mistakes in this code:

su -c "/sbin/fdisk -l
cat /boot/grub/manu.lst

It should be:

su -c /sbin/fdisk -l
cat /boot/grub/menu.lst

As you said,bios will search for bootloader in MBR and it will find it,then GRUB will point to Vista's loader if you select to boot into it and it will do that by chainloading because GRUB can't boot into Windoze directly.You can read more about it here and here.

syg00 03-29-2009 02:04 AM


Originally Posted by alan_ri (Post 3491260)
syg00,there are some typo mistakes in this code

Erk - sorry 'bout that. Thought I'd checked it - shouldn't post while watching the Grand Prix ...:rolleyes:

Ranti 03-30-2009 02:13 AM

Ok, yesterday i've spent most of the morning and afternoon trying to solve this problem. But couldn't solve this problem.its like a cat and mouse game. Vista was installed on my hdd and then i tried to install fedora 10 which was 64 bit and my installed vista is 32 bit. after installing fedora, it was booting perfectly but when i tried to boot vista from the grub menu, it showed me an error- BOOTMGR missing Press CLTR+ALT+DEL to restart. after googling around to fix this problem i find some solution. I boot with my vista dvd and enter in the rescue mode. then putting the following command in command prompt-

bootrec /rebuildbcd

bcdedit /export C:\BCD_Backup

ren c:\boot\bcd bcd.old

bootrec /rebuildbcd
bootrec /fixmbr
bootrec /fixboot

after couple of try it actually worked and i clould get into vista again. but there were no option to go inside fedora. so I again restarted my pc with fedore dvd and enter into the rescue mode and tried to reinstall grub. and actually successfully installed grub. but then when i tried to reboot again grub menu came and booting into fedora was fine however booting into vista again showing the same error msg- BOOTMGR missing press CTRL+ALT+DEL to restart

so this is the situation. maybe there is some compatibility issue with 32-bit vista and 64-bit fedora.

alan_ri 04-03-2009 10:32 AM

Is Fedora on the logical partition? If it's not that would be the problem most likely,if so create extended partition and few logical partitions on it.Maybe for /root,/home and swap for example.Vista should be installed first.
I had Vista and Fedora long time ago on the laptop with Grub and everything was great.
You asked for bootloader,well I used GAG before.It's great.

yancek 04-03-2009 09:07 PM

If you are now able to boot Fedora, you should log in as root and enter 'fdisk -l' command (w/o quotes, lower case Letter L) and post the output here. This will give us your partition information. Also post the output of /boot/grub/grub.conf file.

All times are GMT -5. The time now is 11:47 AM.