-   Linux - Newbie (
-   -   Dual boot install - ubuntu studio 9.04 - GRUB error 21 (

illnamiqui 08-11-2009 07:14 AM

Dual boot install - ubuntu studio 9.04 - GRUB error 21
Hi everyone,

I am new tu Linux and this is my first install.

I wanted to install Ubuntu Studio 9.04 in a Dell precision 670 Workstation. I have Windowx xp installed so I wanted to have both.

During the installation everything seemed fine, but when rebooted i get the error:
GRUB Loading stage1.5

GRUB Loading, please wait...
Error 21

I have 2 hard drives in a RAID array
CERC 2s#0-#0 ARRAY0

During the installation it asks if i want to activate Serial ATA Raid devices, i chose: yes

The partitions look like this:

/dev/sdc5 (root file system)
/dev/sdc6 (SWAP)

I have tried entering in rescue mode and reinstall GRUB boot loader
but then i don't know which option i should use
(hd0) - /dev/hda
(hd0,1) - /dev/hda2
(hd2,4) - /dev/sdc5
(fd0) - /dev/fd0

I have searched for the GRUB 21 error, and read about changing something in the bios or something like that but i have no idea what to do...
Can anyone guide me please?

Thanks for your time!

yancek 08-12-2009 08:35 PM

Grub Error 21: Selected disk does not exist
This error is returned if the device part of a device- or full file name refers to a disk or BIOS device that is not present or not recognized by the BIOS in the system.

If your root filesystem for UBuntu is indeed on sdc5, issuing the following commands from a command line from your Ubuntu Installation CD:

sudo grub
root (hd2,4)
setup (hd0)

What happened to sdb? Did you have another dirve attached during the install? The error above indicates Grub is looking for its boot files on a disk no longer attached, or at least not correctly named in menu.lst file. I don't use RAID so I don't know what impact that might have.

sysfce2 08-13-2009 11:40 PM

How bad do you want to keep your RAID array?
I believe it is possible to install on a RAID array, but it is much more difficult.
I tried for a couple of days and couldn't get it to work (keep in mind I am a Linux newbie), so I destroyed the RAID array and reinstalled Windows and Linux on separate hard drives. It was relatively easy at that point.

EDIT: Installing Linux on RAID is one thing - no problem. Using the RAID drive to boot from is where I ran into problems - a possible solution is to use a non-RAID device to boot (or maybe the windows boot manager).

PhilP 12-03-2011 07:31 AM

Similar Problem - Grub Error 21 on a SiI RAID Setup
This thread looked the most relevant to my situation.

I am trying to install Ubuntu Feisty Fawn onto my old A7N8X motherboard PC when Windows XP packed up for good. I've basically no idea what I'm doing, but the install seemed to go ok until I tried to restart and got the dread "Grub error 21".

I suspect it's something to do with the fact that I've two 500 gB disks in a striped Silicon Image RAID from the preceding thread, but I'm guessing really.

I can't undo the RAID as when I boot up and do F4 into the RAID setup, the keyboard will not respond - no, not even with a PS/2 keyboard which I've tried.

fdisk -l gives this list if that helps:

Device Boot Start End Blocks Id System
/dev/sda1 1 8585 68958981 83 Linux

/dev/sdb1 1 30256 243031288+ 82 Linux swap / Solaris
/dev/sdb2 * 30257 60329 241561372+ 83 Linux
/dev/sdb3 60330 60801 3791340 5 Extended
/dev/sdb5 60330 60801 3791308+ 82 Linux swap / Solaris

Any advice gratefully received.


yancek 12-03-2011 05:51 PM

I don't know anything about RAID so I don't know what impact that has if any. You said you had two 500GB drives yet your fdisk output only shows one drive and that is sdb which generally means the second drive. When you install Ubuntu, the partition manager which usually says Allocate Drive Space, has a Device for Bootloader installation and there is a drop down box. You can select either drive you have to install to its master boot record or you can select a partition. If Ubuntu is all you have, you would want grub in the master boot record of whichever drive is set to first boot priority in the BIOS.

Are both your drives recognized in the BIOS?

I don't know which number version Feisty Fawn is but if it is earlier than 9.10, it would have Grub Legacy, later would be Grub2.
You could go to the site below and download and run the bootinfoscript to gather detailed information on your system and boot files and post it here:

All times are GMT -5. The time now is 09:47 PM.