LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-19-2016, 03:38 AM   #1
newGuy@RHEL
LQ Newbie
 
Registered: Jun 2016
Posts: 27

Rep: Reputation: Disabled
Unhappy Dual boot grub boot not displaying


I installed dual boot for window 7 and Ubuntu 14.04.4 with my onboard VGA years back. Recently, i bought a NVIDIA card GTX Titan X. Successfully, i install the NVIDIA Graphic driver 375.2 through using onboard VGA.
when i use graphic card to display, the grub boot menu is not displaying out( blank screen) and boots into Ubuntu like it always does. I change back to Onboard VGA(My graphic card still seats on MotherBoard) the Grub boot menu, display out.
  • Using On board VGA, able to see grub boot menu
  • Use Graphic card unable to see grub menu


i try removing 'quite splash' and add in 'nomodeset' it still the same results.

please help me, i need to see the grub menu to boot into Windows.
 
Old 12-19-2016, 11:44 AM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Hi:

Since the onboard GPU displays the Grub Menu but under your new GPU Grub does not show, I suspect that the Nvidia driver needs tweaked? Sorry I'm not good with manipulating drivers.

Quite splash and nomodeset are the only paramaters that I know of to pass to the kernel so I'm out of ideas. Maybe other members will see your thread and chime in.

Another idea would be installing Grub Customizer. That may or may not help.

Try installing a background image for your Grub Menu.
https://help.ubuntu.com/community/Grub2/Displays
http://askubuntu.com/questions/61431...ge-grub2-color

https://wiki.archlinux.org/index.php...ips_and_tricks
 
Old 12-19-2016, 11:52 PM   #3
newGuy@RHEL
LQ Newbie
 
Registered: Jun 2016
Posts: 27

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Ztcoracat View Post
Hi:

Since the onboard GPU displays the Grub Menu but under your new GPU Grub does not show, I suspect that the Nvidia driver needs tweaked? Sorry I'm not good with manipulating drivers.

Quite splash and nomodeset are the only paramaters that I know of to pass to the kernel so I'm out of ideas. Maybe other members will see your thread and chime in.

Another idea would be installing Grub Customizer. That may or may not help.

Try installing a background image for your Grub Menu.
https://help.ubuntu.com/community/Grub2/Displays
http://askubuntu.com/questions/61431...ge-grub2-color

https://wiki.archlinux.org/index.php...ips_and_tricks
Thanks for your reply.

Its not onboard GPU display. its just a normal VGA Port display.
I have try different driver version of 361.5, 370.2, 375.2.
All are the same issue.
 
Old 12-20-2016, 03:52 AM   #4
aragorn2101
Member
 
Registered: Dec 2012
Location: Mauritius
Distribution: Slackware
Posts: 567

Rep: Reputation: 301Reputation: 301Reputation: 301Reputation: 301
Hi,

Can you please try something:

- Switch back to the original kernel's driver "nouveau", i.e. uninstall the proprietary driver.
- in the grub.cfg change line where there is "quiet splash" to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=1"
- and remove any occurence of "nomodeset" anywhere.
- finally update the configs: sudo update-grub

All the best.
 
Old 12-20-2016, 04:01 AM   #5
newGuy@RHEL
LQ Newbie
 
Registered: Jun 2016
Posts: 27

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by aragorn2101 View Post
Hi,

Can you please try something:

- Switch back to the original kernel's driver "nouveau", i.e. uninstall the proprietary driver.
- in the grub.cfg change line where there is "quiet splash" to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.modeset=1"
- and remove any occurence of "nomodeset" anywhere.
- finally update the configs: sudo update-grub

All the best.
Hi
thanks for your reply.
I want to use my GPU card for my graphic display.
Uninstalling the GPU Proprietary drivers, it does not display anything through the GPU card and display a error of i8042 no controller found. it just stuck there
 
Old 12-20-2016, 06:07 AM   #6
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
You might want to try aragorn2101 fix in post #4 and let us know if that allows the GNU Grub Menu to be displayed so you can see it.

Quote:
I want to use my GPU card for my graphic display.
Is the casing with the pins that is attached to your GPU showing out of the back of your pc's tower so you can run a direct cable from your GPU to your monitor?

What distribution are you running?
 
Old 12-21-2016, 01:22 AM   #7
newGuy@RHEL
LQ Newbie
 
Registered: Jun 2016
Posts: 27

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Ztcoracat View Post
You might want to try aragorn2101 fix in post #4 and let us know if that allows the GNU Grub Menu to be displayed so you can see it.



Is the casing with the pins that is attached to your GPU showing out of the back of your pc's tower so you can run a direct cable from your GPU to your monitor?

What distribution are you running?
Hi, thanks for your suggestion.
I'm using ubuntu 14.04
The Nvidia card display i8042 no controller found and stay it there.

Last edited by newGuy@RHEL; 12-21-2016 at 01:24 AM. Reason: yes i can connect to the GPU directly and display to my monitor directly
 
Old 12-21-2016, 12:17 PM   #8
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176Reputation: 1176
Did you edit the grub.cfg file with the argument aragorn2101 wrote for you?

Look on your system for additional drivers and see what's in there.

Does your BIOS see the new nvidia card?

http://askubuntu.com/questions/65272...the-model-of-c

Last edited by Ztcoracat; 12-21-2016 at 12:44 PM.
 
  


Reply

Tags
dual boot, nvidia drivers, ubuntu 14.04


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub menu doesnt load at startup : dual boot : grub in the /boot partition jayesh.bhoot Linux - General 7 10-23-2010 03:58 AM
Installed Fedora as dual boot but Grub boot menu is not showing up nilocjin Linux - Newbie 4 06-03-2009 02:09 PM
Two hard disks - dual boot ( XP - Linux ) using microsoft boot loader, not grub cristy88 Linux - General 2 12-17-2007 06:26 PM
No Grub menu displaying on dual-boot (2 hdd's) JoeLinux117 Linux - Newbie 10 03-19-2007 01:23 PM
Fedora Core 3 Dual Boot, Dual Hard drives, Grub Boot Loader Denali03 Linux - Newbie 1 03-04-2005 01:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:25 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration