LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-10-2011, 01:16 PM   #1
nam5301
LQ Newbie
 
Registered: Feb 2011
Posts: 1

Rep: Reputation: 0
Question DUAL BOOT Backtrack Linux & Windows XP Pro from separate HDD's with GRUB


BIOS DEVICE BOOT ORDER
Image link: http://img809.imageshack.us/img809/5...sbootorder.jpg

DEVICE STARTUP SCREEN
Image Link: http://img140.imageshack.us/img140/3...rtupscreen.jpg

WINDOWS IN GRUB MENU
Image link: http://img708.imageshack.us/img708/2586/bootorder2.jpg

GRUB MENU.LST
Image Link: http://img573.imageshack.us/img573/6056/grub.jpg

GRUB MENU
Image Link: http://img638.imageshack.us/img638/1...ubbootmenu.jpg

WINDOWS STARTUP (THIS SCREEN FREEZES HERE, DOES NOT LOAD WIN XP)
Image Link: http://img96.imageshack.us/img96/628/winxpstartup.jpg

Okay, so I am really having a hard time with configuring DUAL BOOT for Backtrack and Windows XP. Each are installed on its own physical hard drive (Both IDE). Windows XP is installed on MAXTOR 6L020J1-(PM). While Backtrack is installed in WDC AC310000D- (SS) <--western digital HDD. I set the first boot as WDC AC310000D-(SS) which is where Backtrack is installed in order to gain access to GRUB Boot Menu. Because I want to be able to choose which operating system I want to boot from the Menu's list. But I can't get it to work. The current configuration are shown on those image links above. I have the MAXTOR HDD set has (hd1,0) which is correct (i think) because it displays the "Starting Up" screen before it loads the Windows XP startup logo. But the problem is that the "starting up" screen just hangs there and does not load anything after that. Not sure what the problem is.
If anyone who is good at GRUB, please lead me to the way to the land of solutions, where the water is clear and the sky is blue, and where Linux, Apple, Windows hold hands.
 
Old 02-10-2011, 09:05 PM   #2
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 309Reputation: 309Reputation: 309Reputation: 309
Code:
title           Windows XP Professional
root            (hd1,0)
savedefault
makeactive
chainloader     +1
map (hd0) (hd1)
map (hd1) (hd0)
Try adding the map command to your entry to trick XP into thinking it is on hd0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I had a windows xp pro 64 & ubuntu 10.4 dual boot in which I had to reload windows. JEBUP2JE Ubuntu 2 09-24-2010 12:35 AM
No Grub menu displaying on dual-boot (2 hdd's) JoeLinux117 Linux - Newbie 10 03-19-2007 01:23 PM
Transfering hard drive w/ linux from separate computer to dual boot with Windows comp SonicGT Linux - Newbie 1 03-18-2006 02:56 PM
SuSe 10, Win XP - dual boot, 2 seperate HDD's, GRUB question Thanh-BKK Linux - Newbie 6 12-06-2005 08:21 PM
Dual boot issue w/ WinXP Pro & Mandrake 10 using GRUB Adam A Flynn Linux - General 6 06-08-2004 09:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration