-   Linux - Newbie (
-   -   downgrade kernel (

DrOzz 05-18-2003 12:04 PM

downgrade kernel
ok i am running MDK 9.1 which uses kernel 2.4.21-0.13mdk as most of you my question would i go about downgrading to kernel 2.4.18...
i have the following files....
kernel- md5 OK
kernel-enterprise- md5 OK
kernel-headers-2.4.18-26.1mdk.i586.rpm: md5 OK
kernel-secure- md5 OK
kernel-smp- md5 OK
kernel-source-2.4.18-8.1mdk.i586.rpm: md5 OK

so i would like to have someone tell me if out of them files i have above, do i have all necessary files, and if not which other ones should i get....and of course how do i go about getting this done...

Proud 05-18-2003 12:34 PM

Erm, have you compiled any apps for your install yet? I think some pre-compiled rpm files might be dependant on your kernel version-best to pick the kernel at install and not change/downgrade it.

DrOzz 05-18-2003 01:28 PM

well this is the thing...i haven't really done anything since putting mdk9.1 on my box...i am trying to get the nvidia drivers to work for my geforce2mx400 card, and i know of people getting them to work when they downgrade to a stable kernel....because the kernel is unstable that comes with mdk9.1....all i know when i try to do a simple rpm -ivh with the kernel header files it just says in conflicts with all kinds of files in the /usr/include folder and it aborts the install....
and just to fill you in, why i am going threw this, is because when i install the nvidia drivers as is, when i type in startx it just hangs at a black screen and you have to reboot with the restart button

MasterC 05-18-2003 01:36 PM

Did you edit your XF86Config-4 file according to the README doc? If not, that could be your problem...

Also, instead of using the RPM file (assuming you are using that) use the .run file.


DrOzz 05-18-2003 01:40 PM

ok first off, i have no problems with the install of the nvidia drivers...and yes i did edit the XF86Config-4 file...i have added many more options like the nvagp but this is not the problem...the installer runs fine, and i have used the shell script install, and also did try the rpms, but that is not when i am presently working with...i have tried everything, there is even known fixes by setting some things in the bios and whatnot, but again i still have had no luck along with many others.. this is why i am resorting to the downgrading of the kernel because a couple of people have tried downgrading to a stable kernel such as 2.4.18 and have had i have nothing to lose and that is what i wish to try...and that is why i am here trying to find out how i go about this...

MasterC 05-18-2003 01:54 PM

Just trying to help you so you don't have to downgrade. That should be the last ditch effort, and I was just making sure it actually was ;)


Should be the only ones you need to do the downgrade. What I suggest is to instead use urpmi to do it:
urpmi kernel-2.4.18
And see if it works. If not, then resort to the standard RPM's.


DrOzz 05-18-2003 02:01 PM

well thx for keeping with me here and trying to help me through this, and i did try the command you said and it worked for both the:

but again when i tried it on the following...

its says it conflicts with files in that same directory....
anymore ideas ?

and btw, whats the difference between the way you told me to do it (urpmi) and the way i did it (rpm -ivh) although it didn't help really, i am just curious...

oh and btw i just copied a little section of the conflicting errors...just to show you what it is saying...but again there is alot more than what i am showing i just took a tidbit to give you the idea..


file /usr/include/linux/wanrouter.h from install of kernel-headers-2.4.18-26.1mdk conflicts with file from package glibc-devel-2.3.1-10mdk file /usr/include/linux/watchdog.h from install of kernel-headers-2.4.18-26.1mdk conflicts with file from package glibc-devel-2.3.1-10mdk file /usr/include/linux/wireless.h from install of kernel-headers-2.4.18-26.1mdk conflicts with file from package glibc-devel-2.3.1-10mdk file /usr/include/linux/xattr.h from install of kernel-headers-2.4.18-26.1mdk conflicts with file from package glibc-devel-2.3.1-10mdk file /usr/include/linux/zorro.h from install of kernel-headers-2.4.18-26.1mdk conflicts with file from package glibc-devel-2.3.1-10mdk

MasterC 05-18-2003 02:10 PM

I'm just guessing but I think those errors are because that kernel (2.4.18) was compiled with a different gcc version, an older one, using an older glibc; which (taken for what it's worth) means that it won't work (very well if at all) on a system compiled with new glibc/gcc such as the case with newer mandrake releases.

In a nutshell:
You might have to compile a 2.4.18 kernel yourself. Not a big deal, just not a good thing for a n00b to have to do. I don't know your level of experience so it might not be a big deal for ya.

The difference in:
urpmi linux-2.4.18
rpm -ivh filename.rpm
Is that urpmi will take care of figuring out which other files you need ;) Also, it will get the latest files for you (if you setup a mirror in your Mandrake Control Center) for updates.


DrOzz 05-18-2003 02:19 PM

well my level of experience isn't all that detailed when it comes to linux, but i would love to know a stepping stone to get me started on how i would go about compiling the kernel myself....i may not have done it before but i would want to know, just to learn and also to try and resolve my problem....and info would be appreciated...

MasterC 05-18-2003 02:41 PM
There is actually a thread dedicated to this. It's not really slackware specific, but it's posted in the slackware section.


DrOzz 05-18-2003 02:42 PM

thx d00d i'll look at it and see if i can grasp it :D

DrOzz 05-18-2003 02:51 PM

actually d00d i have one question..i was just looking at my lilo.conf file and at the end it has the entry:

append=" devfs=mount hdd=ide-scsi acpi=off quiet"

does this mean when i installed them other two rpms, that the kernel did install?

MasterC 05-18-2003 03:08 PM

It at least means that it properly edited your lilo.conf file. You could test it out, it's possible that NVidia's installer doesn't need the headers file.


DrOzz 05-18-2003 03:10 PM

well right now i am following the steps in that post, so i will just finish doing that cause i am almost completly done..just have to wait for the make install to finish, then i have to do the make modules...

MasterC 05-18-2003 03:15 PM

make install? I thought that was slack specific. If not, make sure you've backed up your lilo.conf...



All times are GMT -5. The time now is 10:00 AM.