-   Linux - Newbie (
-   -   Dovecot - cannot donwload mail from outlook (

linuxexpress 11-17-2008 04:31 PM

Dovecot - cannot donwload mail from outlook
Hi, I installed mail server with postfix and dovecot service installed at Fedora 9.

At the Fedora box, I can sent mail and receive mail (mail sent from I have window box using the Fedora box as mail server and I cannot download mail at the window box using outlook

When I try to receive mail from outlook, it always ask for user name and password.

For the dovecot.conf, I set up using the default without changing anything except one line:

protocols = imap pop3

# netstat -l|grep tcp
tcp 0 0 *:35383 *:* LISTEN
tcp 0 0 *:smtp *:* LISTEN
tcp 0 0 *:* LISTEN
tcp 0 0 *:https *:* LISTEN
tcp 0 0 *:pop3 *:* LISTEN
tcp 0 0 *:imap *:* LISTEN
tcp 0 0 *:ssh *:* LISTEN
tcp 0 0 *:smtp *:* LISTEN
tcp 0 0 localhost6.localdomain:rndc *:* LISTEN

- for the firewall, I allow pop3 and smtp

# telnet localhost 110 ( from Fedora box)
Connected to localhost.
Escape character is '^]'.
+OK Dovecot ready.

#telnet 110 ( telnet from window box and is the internal ip address of Fedora box)

+OK Dovecot ready

# service dovecot start
Starting Dovecot Imap: [ OK ]

Any idea whats go wrong

billymayday 11-17-2008 04:33 PM

Are you suggesting dovecot shouldn't ask for a username and password? How else does it know what user's mail you are looking for.

Aside from that, there should be messages in /var/log/maillog

linuxexpress 11-17-2008 04:59 PM


pop3:login:Aborted login(0 authenifiication attemps): rip=::ffff:,lip=::ffff:,secured

linuxexpress 11-17-2008 07:19 PM

When outlook asked for username and password, I entered the correct information and it still asked for username and password

billymayday 11-17-2008 09:12 PM

What type of authentication is dovecot set up for in dovecot.conf, and what's the setting for disable_plaintext_auth in dovecot.conf?

osamaensyviswinkel 11-18-2008 05:57 AM

so you can telnet to pop3 locally on the machine, and from the windows to the linux box - so that seems fine.

1. have you tried setting that mail account up and test it in a different mail client and see if that works (example, express, or thunderbird, etc.)
2. what error does the mail client give when it tries to pop the mail (sure it's not a client problem?)

linuxexpress 11-18-2008 10:51 AM

The devcot.conf is in default setting. All the parameters in the devot.conf is commented by default. The only paramter that I uncommented is the protocols as below:
protocols = imap pop3

The disable_plaintext_auth in the config file is commented by default as below:
# disable_plaintext_auth = no

billymayday 11-18-2008 01:34 PM

DO you have another mail client like thunderbird you can try to see if it's an outlook specific issue?

billymayday 11-18-2008 02:12 PM

Can you also test with SELinux disabled ("setenforce 0" to turn off, "setenforce 1" to turn back on).

Did you install dovecot using yum?

Also, check your secure log (/var/log/secure) to see if there are any messages at the same time

linuxexpress 11-18-2008 04:45 PM

Selinux is disabled.

I tried to use Thunderbird to download mail but cannot download mail from Fedora box.

No log messages find for /var/log/mail/log and /var/log/secure.

Dovecot is installed through yum

billymayday 11-18-2008 04:50 PM

Might be worth removing dovecot and reinstalling, just in case something went wrong in the initial instyallation. Try leaving the config untouched initially.

I assume you use PAM for your normal user authentication (ie to log on)?

linuxexpress 11-18-2008 05:05 PM

I reboot the machine and now there are log recorded from /var/log/maillog

Nov 18 18:01:17 testserver dovecot: pop3-login: Login: user=<joe>, method=PLAIN, rip=::ffff:, lip=::ffff:
Nov 18 18:01:17 testserver dovecot: POP3(joe): Couldn't init INBOX: Mailbox isn't a valid mbox file
Nov 18 18:01:17 testserver dovecot: POP3(joe): Mailbox init failed top=0/0, retr=0/0, del=0/0, size=0

billymayday 11-18-2008 05:08 PM

Well that's good.

Do you know if that user has any mail?

linuxexpress 11-18-2008 05:11 PM

I sent some test mails to this user from and all these mails are received at the fedora /var/spool/mail/joe

billymayday 11-18-2008 05:23 PM

That sounds like a corrupted mbox. If these are only test messages try deleting the file joe and send another message.

Before you do that though, what's the output of

ls -l /var/spool/mail/joe

All times are GMT -5. The time now is 11:55 PM.