LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Doesn't shutdown normaly !!! (https://www.linuxquestions.org/questions/linux-newbie-8/doesnt-shutdown-normaly-90797/)

Anmar 09-09-2003 03:22 AM

Doesn't shutdown normaly !!!
 
When I logout to shutdown the system it kills everything except the last kill proccess .

I mean I have to push the power button manually (By myself)

It doesn't shutdown,,, REALLY ANNOYING .


What to do ?
:cry:

nephilim 09-09-2003 03:24 AM

the APM module probably isn't installed. Type lsmod and see if APM is running. If it isn't, uncomment the APM line in /etc/rc.d/rc.modules.

XavierP 09-09-2003 03:24 AM

What is the process that doesn't die?

Anmar 09-09-2003 03:40 AM

That command doesn't work.
there no existing lsmod command .

Does that mean APM is not installed ?

About that proccess thing,
Eventually it says it's killing all proccesses signals,
But it doesn't seem it's killing or cutting the power .
I have to shutdown myself by pushing the button .
Very Silly .

nephilim 09-09-2003 03:44 AM

Look into the /etc/rc.d/rc.modules file and see if APM is commented out (if the line starts with a #, it's commented out). Remove the #, reboot and your system should shut down fine.

Anmar 09-09-2003 03:46 AM

Do you believe guys that I still don't understand the affero feature in this site ?!!!

I just couldn't understand the illustration for the affero thing yet !

can anyone one explaine it please ?

Anmar 09-09-2003 03:59 AM

There is no any file called rc.module in that dir !!!

nephilim 09-09-2003 04:23 AM

Sorry about that, that's the way to do it in slackware. I guess redhat has a different approach.

about affero: check out http://www.affero.com/ to answer all your questions.

Shantesh 09-09-2003 04:27 AM

Even I'm facing da same prob somtimes....when i click on logout n try to logout to shutdown da system......the system doesnt responf and i have to manually shutdown my pc....plz help ! :(

Anmar 09-09-2003 04:52 AM

Still don't k'now what an affero is, Screenshots not that much helpful,
Can anyone explaine it please .
I would make a new thread for those affero explainations

Anyways,,,
I also still can't find that file in that directory .

What do you think I should do ?

Anmar 09-09-2003 04:54 AM

Sorry if bothering with the affero thing :)
Just k'new that there is something called an affero page .

XavierP 09-09-2003 05:12 AM

For an explanation of Affero, go to www.affero.com/ca/lq.php

There is a good, simple explanation of what affero is.

Anmar 09-09-2003 05:32 AM

What about the shutdown thing ?

XavierP 09-09-2003 06:02 AM

http://www.linuxquestions.org/questi...threadid=66172
http://www.linuxquestions.org/questi...ght=APM+redhat
http://www.linuxquestions.org/questi...ght=APM+redhat
http://www.linuxquestions.org/questi...ght=APM+redhat

The 4 posts above may have the info you need (or if not, at least more ideas on where to look)

If you want more posts, I did a search on this site on "APM redhat" (minus the quotes).

rberry88 09-09-2003 10:00 AM

I had this exact same problem (issue) with suse 8.2. The way I fixed it was to go into Yast2 -> System -> Boot Loader Configurator. When in here, hit the button on the bottom that says "Edit Configuration" and find where it says "apm=off" and change it to read "apm=on". Then reboot your system and see if it works. Worked like a charm for me.

rberry88


All times are GMT -5. The time now is 08:33 AM.