-   Linux - Newbie (
-   -   Does Fedora core 6 supports dvdrom? (

anant 12-08-2006 09:07 AM

Does Fedora core 6 supports dvdrom?
Hi all,
I would like to know wether FC6 supports dvdrom or not. Because after installing FC6 from dvd including xen, it seems to be not supporting DVD'S. yeh CD'S are working fine but when i put dvd in dvdrom i cant view its contents.
yeh offcourse its dvdrom, i am not playing with cdrom here.
and its version is :
standard IDE : [HL-DT-ST RW/DVD GCC-4481B-(S]
Do i have to install any specific drivers to get it work over FC6 OR the issue is something else? pls help
Any help would be appreciated!!!!!
Thanks in advance

jimmy512 12-08-2006 09:17 AM

Check to see if it is the dvd disk itself. Try it on another computer, or try it in another drive. Sorry if I couldn't help.

anant 12-08-2006 09:22 AM

yeh i have tried in two systems now.First i installed FC6 over paravirtualised system with XEN and second with fully virtualized system .But with both the systems the problem is same, which seems to be FC6 error. Where as if i put that dvd in any windows OS, it works fine.
Yeh it is dvd disk as i installed FC6 from DVD using dvdrom of these system. The problem occured after its installation.
thanks for your reply anyway.

Lenard 12-08-2006 12:22 PM

Yes check the two files (/etc/fstab and /etc/filesystems). The spacing for the device entries is important, if you look at the /etc/fstab file you would see the spacing is similar. To save you the trouble of having to read two threads they are provided below (again);


/dev/hdc                /media/cdrom            auto    noauto,users,ro 0 0

/dev/hdc                /media/cdrom            iso9660,udf    noauto,users,ro 0 0

Remember these are examples of what to look for. And for the sake of completeness here is the /etc/filesystems example;

$ cat /etc/filesystems
nodev proc
nodev devpts

To quickly check from the console or xterm session type;

cat /etc/fstab
cat /etc/filesystems


bibh_lnxq 12-09-2006 04:52 AM

To answer your initial question: yes, in my FC6_64 (stand alone PC) I can access DVD, out of the box, from my user account. I have not changed anything in this department.
To answer the second part of your initial question (is it FC6 or not?) I would suggest that it is not a specific FC6 problem. I am sorry, but I cannot help you with the two methods of virtualisation you mention, but it looks as if the problem lies there.

anant 12-11-2006 05:15 AM

i logged in as a root on terminal and enter dis command
/dev/hdc /media/cdrom auto noauto,users,ro 0 0

but its comaing as permision denied.

well you were right i checked these two files (/etc/fstab and /etc/filesystems) and there was nothing like udf or auto so i added udf in /etc/filesystems by simply going to that file and writing udf and saved it and i did the same for /etc/fstab by going to that file and added /dev/hdc /media/cdrom auto noauto,users,ro 0 0 and saved dt file
as permission ws denied when i tried this command on terminal.
Now i checked this folder dev, under these foldere there were many files like cdrom, hdc, dev-hdc name which were restricted. i tried to change the properties by making owner and group as root but still i am not able to access dvds contents.
Well how should i change the permision then or what exact step would you suggest if i logged inn as a root


ethics 12-11-2006 05:28 AM

? is that the exact command you typed? that's the entry that should go into FSTAB as it's interpretted.

The actual command is mount, followed by those options. It's quite difficult for root to have permission denied since if root can't access it, who can???

In the above i can't see if it has been mentioned what type of DVD it is, does it have a filesystem? in which case the problem seems to be mounting (or lack of) or is it a movie or something? which required libdvdcss in order to decrypt it.

anant 12-11-2006 07:20 AM

thanks all of for replying.
well it was just a permission error, now once again i tried to check after changing some permission properties to see wether its accepting dvd's or not. So it did.
finally its working.
I dont know if it would be allright to ask this question here, ok ill ask
well now after all the working environment i want to install windows OS over xen (FC6), but i got to know that installation is not possible through dvd directly.It could be done using NFS, FTP OR HTTP sharing and i am not sure about this issue. how can i have this share?

All times are GMT -5. The time now is 12:49 PM.