LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   DMA for SATA disk (https://www.linuxquestions.org/questions/linux-newbie-8/dma-for-sata-disk-590181/)

ankit_mcgill 10-08-2007 02:20 AM

DMA for SATA disk
 
Hi all,

I am trying to set up my linux to read dvd movies .. i have install all the libraries and the codecs.

Now my computer reads the DVD but its very jerky .. so i realized i needed to turn on the DMA on for th drive

however when i issued the command i got :

Code:

ANKIT-LAPTOP:/dev # hdparm -d1 /dev/dvd

/dev/dvd:
 setting using_dma to 1 (on)
 HDIO_SET_DMA failed: Inappropriate ioctl for device
 HDIO_GET_DMA failed: Inappropriate ioctl for device

did a bit of googling and found out that hdparm does not support SATA drives ....

now my question is what can i do to turn on the DMA ? right now it takes over an hour to burn a DVD ?!

thanks for all the help
a

masonm 10-08-2007 07:33 PM

You may want to start by checking your BIOS settings.

Hern_28 10-08-2007 09:13 PM

Jerky?
 
More than drive access parameters can give you choppy video. Check your video card setting and make sure you have some sort of video acceleration enabled for the video card. Video was jerky on my system till I re-install the video drivers.

jay73 10-08-2007 09:29 PM

Sata uses sdparm although for some reason I still have to use hdparm for my SATA disks (it seems to me that my motherboard isn't fully supported yet). optical drives, by the way, don't support the high DMA modes that hard drives do. I can get DMA7 for my hard drives but no more than 3 for the optical drives.

As pointed out above, it could just as well be a video driver issue. Play around with the output options (xv, gl, etc.) to see whether it makes a difference. But that wouldn't explain why it takes an hour to burn a dvd, that does seem a DMA issue.


All times are GMT -5. The time now is 07:58 PM.