LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   DIsplay Problem during CentOS 4.7 installation (https://www.linuxquestions.org/questions/linux-newbie-8/display-problem-during-centos-4-7-installation-772928/)

linux4samir 12-02-2009 05:53 AM

DIsplay Problem during CentOS 4.7 installation
 
Dear Friends

I am getting some problem during CentOs 4.7 (x86) installation

During installation, display goes-off after running anaconda ....

My mother board is- Asus A7N266-VM
RAM - 512 MB DDR

Please help me

Thanks

rweaver 12-02-2009 09:48 AM

Have you tried the text mode installation yet? That should alleviate any display problems you're having.

SharpyWarpy 12-02-2009 06:34 PM

What video card do you have? It might be that you need to install a different distribution. At least try. That way you'll know if it's a driver problem with the Centos install.

linux4samir 12-03-2009 12:19 AM

Quote:

Originally Posted by rweaver (Post 3777169)
Have you tried the text mode installation yet? That should alleviate any display problems you're having.

Thanks for you reply

Yes I have sucessfully instaled the same in TEXT mode. But after installation , when i restart the system.....my display goes off (before X-window start)

My Display card in onboard graphics card. (ASUS A7N266-VM)

Thanks

SharpyWarpy 12-03-2009 08:36 AM

Try another distribution.

chrism01 12-03-2009 05:49 PM

Try a more up to date one; RHEL/Centos are currently on 5.4

rweaver 12-04-2009 09:13 AM

It sounds like you may need to update some drivers on the system or configuration files, you might try booting a livecd or booting into text mode and correcting the configurations/changing the setup manually.

linux4samir 12-05-2009 12:33 AM

Quote:

Originally Posted by rweaver (Post 3779761)
It sounds like you may need to update some drivers on the system or configuration files, you might try booting a livecd or booting into text mode and correcting the configurations/changing the setup manually.

I have installed the OS sucessfully under text-mode and also can use all CUI-level command, but whenever i tried to run "startx"....the display automatically goes off..it may be hang...bcoz i cant ping the system form another machine.

I have also tried to configure the display using "system-config-display" but pressing ENTER my system getting hang.

linux4samir 12-05-2009 12:37 AM

Quote:

Originally Posted by chrism01 (Post 3778985)
Try a more up to date one; RHEL/Centos are currently on 5.4

Actually i cant upgrade my os to RHEL/CentOS v5 or higher because i have to install some softwares which are not compitible with said version of the OS.

SharpyWarpy 12-05-2009 07:02 AM

Exactly what software do you need that isn't compatible with a newer version of Centos? Can't you upgrade that too?

linux4samir 12-05-2009 11:12 AM

Quote:

Originally Posted by SharpyWarpy (Post 3780803)
Exactly what software do you need that isn't compatible with a newer version of Centos? Can't you upgrade that too?

well its a Accounting software running under "Oracle 9i"

carltm 12-05-2009 12:33 PM

Quote:

Originally Posted by linux4samir (Post 3780554)
I have installed the OS sucessfully under text-mode and also can use all CUI-level command, but whenever i tried to run "startx"....the display automatically goes off..it may be hang...bcoz i cant ping the system form another machine.

I have also tried to configure the display using "system-config-display" but pressing ENTER my system getting hang.

I've had similar problems in the past. I always start by
installing the OS in text mode, because it's a whole lot
easier to troubleshoot and fix the problem after the OS is
installed.

I would start by looking at the output of lspci since that
will let us know what hardware you're working with. We can
then figure out the best way to get x running.

linux4samir 12-05-2009 11:29 PM

Quote:

Originally Posted by carltm (Post 3781035)
I've had similar problems in the past. I always start by
installing the OS in text mode, because it's a whole lot
easier to troubleshoot and fix the problem after the OS is
installed.

I would start by looking at the output of lspci since that
will let us know what hardware you're working with. We can
then figure out the best way to get x running.

HERE IS MY OUTPUT OF "lspci" COMMAND
*******************************************

00:00.0 Host bridge: nVidia Corporation nForce CPU bridge (rev b2)
00:00.1 RAM memory: nVidia Corporation nForce 220/420 Memory Controller (rev b2)
00:00.2 RAM memory: nVidia Corporation nForce 220/420 Memory Controller (rev b2)
00:00.3 RAM memory: nVidia Corporation: Unknown device 01aa (rev b2)
00:01.0 ISA bridge: nVidia Corporation nForce ISA Bridge (rev c3)
00:01.1 SMBus: nVidia Corporation nForce PCI System Management (rev c1)
00:02.0 USB Controller: nVidia Corporation nForce USB Controller (rev c3)
00:03.0 USB Controller: nVidia Corporation nForce USB Controller (rev c3)
00:05.0 Multimedia audio controller: nVidia Corporation nForce Audio (rev c2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce Audio (rev c2)
00:08.0 PCI bridge: nVidia Corporation nForce PCI-to-PCI bridge (rev c2)
00:09.0 IDE interface: nVidia Corporation nForce IDE (rev c3)
00:1e.0 PCI bridge: nVidia Corporation nForce AGP to PCI Bridge (rev b2)
01:07.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
02:00.0 VGA compatible controller: nVidia Corporation NVCrush11 [GeForce2 MX Integrated Graphics] (rev b1)

carltm 12-06-2009 05:47 AM

Quote:

Originally Posted by linux4samir (Post 3781417)
02:00.0 VGA compatible controller: nVidia Corporation NVCrush11 [GeForce2 MX Integrated Graphics] (rev b1)

Okay, now that we know what card it is, the next step is
to configure x. Run system-config-display as root. I don't
recall exactly what you will see, but you will want to verify
that the monitor settings are right and set the card to use
the nv driver. If that doesn't work, you can always select
the vga driver, which works, but doesn't enable any special
features of the chipset.

linux4samir 12-06-2009 09:12 AM

Quote:

Originally Posted by carltm (Post 3781569)
Okay, now that we know what card it is, the next step is
to configure x. Run system-config-display as root. I don't
recall exactly what you will see, but you will want to verify
that the monitor settings are right and set the card to use
the nv driver. If that doesn't work, you can always select
the vga driver, which works, but doesn't enable any special
features of the chipset.

Dear Friend

Plese see my earlier post......I have done this before....but whenever I am trying to run "system-config-display" command my system getting hang. Even I cant ping my system from another machine.

For your help... here is my /etc/X11/xorg.conf

*******************************************************************


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Unknown monitor"
HorizSync 31.5 - 37.9
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
VendorName "Videocard vendor"
BoardName "VESA driver (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


All times are GMT -5. The time now is 07:23 AM.