-   Linux - Newbie (
-   -   display problem (

greenknight 12-30-2009 09:43 AM

display problem
First I will say my real name is Jim allAn. I cap the last name that way because everybody insists on looking for Allen and get disturbed when they don't find me. I have been in and out of Ubuntu for about two years without really learning anything. Being 71 I date back to all dos machines and things like a vic 20 with only 5kb memory and tape drives. I still have a vic 20.
On to my real question and reason for being here today. I recently dlded a file that installed Ubuntu all by itself. The problem was there are no options I found to change something like the display. I get to the point where I believe would show the desktop when the screen screws up and lays on it's side with many many lines. I am guessing I need to change the display mode or something. I have seen it react to the k board or mouse, but it is totally impossible to read it. I have gotten to a cmd line but don't really don't remember how. I have used a man page to test the dos mode. It works.
I am hoping that,since I am on a shared broadband I don't need a modem so it just might go online. I really want to get there so I can talk with people direct from Linux to find out things. I think I have already found some good info sites.
I better tell you what I am using before I forget. I use an old dell tower mch running win xp pro and Ubuntu through grub for duel booting. I do try to get to a local user group called Southerntier ny lug but transportation is a problem. Stnylug seems to be a great bunch of people.

business_kid 12-30-2009 12:50 PM

Try X -configure
man xorg.conf

Tidy up your posts. This isn't a blog.

greenknight 12-30-2009 04:01 PM

More tidy posts will come quickly. This is my first time here.
I didn't know how I might post a follow-up but here goes.
An ubuntu 9.10 disk just arrived and I made much progress. I started through install and all went ok until I came to importing settings and such. I am operating in a safe graphics mode until I find a better option. On the import page I found no way past it. I think the page, in current mode, is to tall putting the options below the page. I have seen it before.
I am probably better off going with the disk rather than trying to fix the original display problem. What ever you people say is best I will try.
It did go online reading suggested stuff, so I am real happy at this point.
Thanks much for the help thus far.

business_kid 12-31-2009 04:10 AM

X -configure tidies up the configuration of X automagically.
The lines lying sideways or diagonally means the monitor isn't able to do the speed it's been asked. Ususlly it's being asked to go faster, but sometimes slower.
Find out the max refresh rates (horizontal & vertical) your monitor does in Khz, and Hz respectively. Let's say it 55KhzThen you need two lines in xorg.conf

HorizSync 31.5 - 55 # Meaning 31.5 - 55 Khz
VertRefresh 50 - 75 # Meaning 50-75 Hz

search for those terms in xorg.conf

grep HorizSync /etc/X11/xorg.conf to make sure there's not another setting and restart X

malekmustaq 12-31-2009 10:31 AM


I understand your situation as you have well explained above. When I was at your newbie stage I first sought out a tutorial to hasten up my 'familiarization' with the new OS. Download this well written tutorial, quite old but nevertheless it has everything that a newbie commonly looks for. You don't need to read it all at once: each time you need to know something you can browse the Table Of Contents for a lead.

To configure your display size, launch a terminal (dos prompt or shell) from Menu > Accessories > Terminal Emulator, then enter this command:

green@host-$ X configure

a help or choices of options are offered, read and find which of it you need. All other Linux commands mostly you find help by typing into the terminal $ man "command". To learn about the 'X configure' command you will type:

green@host -$ man X configure

Get a full introduction from Paul Sheer on the tutorial you downloaded. To the basic minimizes our dependence to other which usually are not that quick.

Hope this helps.

Good luck.

greenknight 12-31-2009 10:39 AM

The directions given to fix my display speed do not seem to difficult. My problem is how to implement them if I can't access a cmd line. How do I get to the cmd line.
I assume I would need to interupt the boot/install procedure. I did say I had been on a cmd line but don't remember how I got there during install.
The only thing I was able to find in windows was that display is running at 60hz with no apparent other speeds. I have seen the present results of setting it to fast on other monitors.

pixellany 12-31-2009 11:03 AM


Originally Posted by business_kid (Post 3809052)
Tidy up your posts. This isn't a blog.

Lighten up, please. His post was WAY above average on the tidymeter....

pixellany 12-31-2009 11:08 AM

Ways to get to command line:
  1. ctrl-alt-F1 (or F2, F3, etc.----typically there are 6 setup: F1 thru F6)
  2. single-user mode: When the grub menu appears, hit any key to stop the countdown. Then hit "e" for edit, select the kernel line, "e" again, and add the word "single" (no quotes) at the end. Hit enter and then "b" to boot.
  3. And of course, just open a terminal from the GUI

malekmustaq 12-31-2009 01:04 PM


How do I get to the cmd line.
I assume I would need to interupt the boot/install procedure.

No you don't need to do it, yea I remember, under M$windows we needed to foil the boot sequence in order to enter repair-mode equipped with a command line, but with Linux, as do other Unix like, the terminal (command line) is always available even if X-window is at full-throttle. The shell, a real time terminal running outside the Xwindow, is available by pressing Ctl-Alt-F1, F2,F3,F4,F5 whichever is set available by the init, just follow the instructions given by pixellany above. If there is no need to do things outside the Xwindow you only need to launch the terminal from the Menu button, the third option in the list of pixellany above given.

Reminder: it is always good to work configuring X window when it is not running. So, normally, you have to logout from current user, then at the login dialogue find a button that offers a 'terminal login' or you may just leave it and opt to press any of the choices of combination in the #1 of pixellany's list above, login as 'root', then you have all the power to make or unmake your system.

Hope this helps.

Good luck.

BTW greenknight thank you for pressing the blue button, it makes an oldman's heart feeling a bit younger. :)

greenknight 12-31-2009 05:47 PM

I hate it when something like this makes me look like a complete idiot.
I assume by grub menu you mean the choice between windows or ubuntu. I hit any key and the display freezes. I hit e and nothing happens. I hit it again and still nothing happens. I try crtl alt f keys and again nothing happens. I even tried it at the language choice window. Zip.
Am I stupid or does this thing really have a mind of it's own.

malekmustaq 01-01-2010 08:02 AM


Be patient, no newbie ever passed easily from the horizon of idiocy. :) we were there before.


I assume by grub menu you mean the choice between windows or ubuntu.
Yes you got pixellany right.


I hit any key and the display freezes.
Well, that's not the way Grub wanted it to be so probably it did not understand and stopped doing wanting to leave the scene.

The correct way to stop Grub from counting the seconds is to hit 'Esc' or 'Tab' keys, then it will offer you another Blue-Red-White screen command dialogue box.


I hit e and nothing happens. I hit it again and still nothing happens. I try crtl alt f keys and again nothing happens.
Yes, it freezes.


I even tried it at the language choice window. Zip.
Am I stupid or does this thing really have a mind of it's own.

No, you are not. You and Grub just needed another time to learn to know each other. So, read this good Grub tutorial page it is short but you don't need to read it all at once. Just cull from it the subject you currently need most.

When the 'e' does not respond it means something was wrong that grub cannot go on to accommodate edited commands, you will need to reboot, Ctl+Alt+Del, then wait until the moment you rightly press Esc or Tab.

Hope this helps.

Good luck.

greenknight 01-01-2010 10:59 AM

I am sorry to say it still does not work. I tied all the combinations, I think, Esc and tab in both win highlighted and Ubuntu highlighted. They all stoped the clock, but no response to e. GRRR! Maybe something is messed up because I have tried both the disc and the wubi thing. Since the wubi got me the most, again I think, I will try that again. No, the disc would be faster so I will try that.

tredegar 01-01-2010 12:12 PM

You don't need to edit grub to get to the command line.
One of your grub entries will be Ubuntu ..... (Recovery mode).

Select that one with the Up/Down arrow keys, then press Return.

It boots and a menu appears
Choose "Drop to root shell prompt" with the Up/Down arrow keys, then press Return.

Enter YOUR password (nothing be printed on the screen as you type, but it's working)
Press Return.

Now you are root, and can try all the tricks to configure your X server properly (see above).

Most posts seem to recommend a simple

dpkg-reconfigure  xserver-xorg
as being a good fix-all in the first instance.

( X --configure did not work for me, and I had to <CTRL>-C to abort the X server startup, which had frozen )

Then you can type reboot to do just that when you press the Return key.

This time, don't choose the recovery mode.

greenknight 01-01-2010 12:36 PM

I don't believe it. It finally went all the way through the installation. What I did different could not have affected it.
While it was in the early stages I Tried interupting it like I was in grub. I tried e a feww times and nothing. Even tried eee and nothing happened. I need to take that back. When I first interupted it I did get the usual shadow password thing. Then I tied the e thing. Eventually it went to the text screen which normally comes up showing different things it had done. Finally the install options came up.
I tried the live disc and it failed. I started again trying to actually install Ubuntu. It went normal like expected. When it came to the import page, I fooled with that finally importing nothing. Then I noticed the continue options were there. Of course I continued always accepting default where possible.
I finally ended up on the login page. Actually I did get this far before but couldn't get by the password. This time I did. The screen is still messed up but the first part of grub was entirely different. There were five options. Four for Ubuntu and one for windblows. The good thing at this time is it explained the e thing. I assume it will work. There was also mention of a recovery thing I think. Then it went to the second grub screen.
Needles to say I am happy with it as is for now. I will try the e instructions after lunch. I need a pause anyhow.

greenknight 01-01-2010 04:09 PM

I got it part way working. I was already root for some reason which doesn't seem right. The dpkg - reconfigure xserver - xserver - xorg
and x configure both were accepted but not all the way. Both cmds said things marked with (*) give a lot of output. Pipe through less or _. I haven't learned pipe yet so stopped to do more studying. I think we are getting closer. Thinking is a thing a man should not do.

All times are GMT -5. The time now is 09:06 PM.