LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   display problem (https://www.linuxquestions.org/questions/linux-newbie-8/display-problem-143139/)

plainwlkr8 02-06-2004 06:49 PM

display problem
 
ive tried fixing my display. im running rh 9 and i use gedit to configure my XF86Config file. the highest res i can get (and its been higher before) is only 1024x786. ive added other resolutions but they just erase when i add them, and save them to the file. here is my config.

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Unknown monitor"
HorizSync 31.5 - 37.9
VertRefresh 50.0 - 70.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x786" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

do i need to make another default depth? refresh rates are horizontal 60-90 kHz, vertical are 50-160 Hz. my monitor is a mag innovision 996PF. what do i need to change so i can add more modes?

XavierP 02-06-2004 06:50 PM

Did you edit the file as a normal user or as root?

plainwlkr8 02-06-2004 06:53 PM

as root yes

XavierP 02-06-2004 07:01 PM

where do you put the new resolution(s)? It/they should go before the "1024x768" in quotes. Then save the file.

plainwlkr8 02-06-2004 07:04 PM

i put them before the listed resolutions but when i save and then restart, it erases them so only the 3 are there

XavierP 02-06-2004 07:07 PM

Are you editing the XF86Config file or the XF86Config-4 file? Do you see the Nvidia logo screen when you boot up?

plainwlkr8 02-06-2004 07:25 PM

XF86Config, no i dont see any nvidia logos when i start up

XavierP 02-06-2004 07:30 PM

If no Nvidia logo, that means that the driver isn't being seen. AFAIK, XF86Config hasn't been used for quite a while. You will need to edit XF86Config-4 - just repeat the changes you made on XF86Config in XF86Config-4. Restart X and let me know if your nvidia logo is coming up and if your new resolution is working.

plainwlkr8 02-06-2004 07:39 PM

dont know what the XF86Config-4 is, im using rh 9, theres only XF86Config and .backup

XavierP 02-06-2004 07:41 PM

Try issuing whereis XF86Cconfig that should bring up all variations of the file. I have used RH9 and that file should be there.

plainwlkr8 02-06-2004 07:46 PM

[joe@localhost joe]$ whereis XF86Cconfig
XF86Cconfig:


thats all that comes up, im going to reinstall my drivers for nvidia and see if that works.

jerrymei 02-07-2004 02:37 AM

Hi,

So files shouldn't be modified manually or changes will be lost. I don't know but my be XF86Config file is that type. So I think it worths if you use the preferences command in the start menu to change your resolution.

Hope it would be useful.

r_jensen11 02-09-2004 05:54 PM

I'm guessing he made a typo. Try whereis XF86Config and whereis XF86config

XavierP 02-10-2004 01:31 PM

Yep - it was a typo. Many apologies. whereis xf86config, issued as root is the correct command.

Apologies again.


All times are GMT -5. The time now is 11:48 PM.