-   Linux - Newbie (
-   -   Disk Quotas (

abhi7514 10-21-2012 09:34 PM

Disk Quotas
I'm practicing new things with Linux/Unix and I need someone to point me at the right direction.
Lets say I create a user named user1. After creating it, how would I enable quotas for it. I have already added "userquota" under "/etc/fstab" and rebooted my system, but after I run the command "quotacheck -avug" I get the following:
~]# quotacheck -avug
quotacheck: Your kernel probably supports journaled quota but you are not using it. Consider switching to journaled quota to avoid running quotacheck after an unclean shutdown.
quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file.
Please turn quotas off or use -f to force checking.

I tired enabling usrquota on root and /home to see if i get something different but same message. I also tried mount -o remount /home which didnt game me any errors but didn't really help either. I would appreciate your feedback.

Thanks in Advance

chrism01 10-21-2012 11:43 PM

Here's a good step-by-step
You mainly seem to have done things in slightly the wrong order, and also missed out creating the quota files via the -c switch.

All times are GMT -5. The time now is 03:59 AM.