LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   disabling display (https://www.linuxquestions.org/questions/linux-newbie-8/disabling-display-94121/)

sumpter 09-18-2003 08:18 AM

disabling display
 
hi folks,

i was trying to install redhat 9.0 on my pc, but when it finished the installation and tried to initialize the system environment, my monitor kept flashing several times and handed me an error message: "failed to start the display server several times in a short time period; disabling display : 0 "
i wonder how i can fix it... i tried to read other forums about this problem, but i didn't understand them cuz i am a real newbie of linux, i sux, so i hope someone can show me a bright way, oooops, my hardware configurations are : geforce 2 MX/MX400 & MagView VM700E -- H: 30-70k Hz and V 50-150Hz

thanks

:newbie:

arunshivanandan 09-18-2003 08:33 AM

Could be some X config problems.Therefore try entering textmode first(runlevel 3).
When you boot up,if you are using grub, edit your kernel parameters(by pressing 'e') by adding a '3'.if you are using lilo,try boot:linux 3.
http://www.redhat.com/docs/manuals/l...ng-single.html explains how to enter single user mode.just replace single in this doc with 3 to enter multy user textmode.After entering it,just try a 'startx'.you may get some errors.then check out your /var/log/XFree.0.log forerrors(they start with ee).post them here.you can try reconguring X (the config file is /etc/X11/XF86Config or /etc/X11/XF86Config-4.the -4 will override the other one if both are there.you can see the name in your log file) using 'redhat-config-xfree86' or xf86config.
If you cant clear the problem post your /var/log/XFree.0.log and the X config file.(see the log file to see whether it uses -4 one or the other).some one may be able to help you out from this.
once again,
X config file is /etc/X11/XF86Config or /etc/X11/XF86Config-4.
X startup log file is /var/log/XFree.0.log.
use texteditors like 'pico' or 'vi' from textmode.
use utilities like
'redhat-config-xfree86' or 'xf86config' to reconfigure X.
ps:It will be better if you delete all your X log files,i.e,
'rm /var/log/XFree.*' before trying 'startx'.


All times are GMT -5. The time now is 10:52 AM.