-   Linux - Newbie (
-   -   Disable firewall on CentOS 64-bit LiveCD (

tnili 09-20-2012 02:53 PM

Disable firewall on CentOS 64-bit LiveCD
Is it possible to disable or reconfigure the firewall on the CentOS Live CD?

Here is the context. I would like to do some testing using the LiveCD. In order to do this, I need to copy files to and from the CentOS host. Now, I am using WinSCP as a client with SFTP as the protocol. This works flawlessly when the CentOS host is installed from the full DVD (version 6.3). However, when using the LiveCD it does not.

The initial problem was that sshd was not running on the LiveCD. This service automatically starts sftp-server when it detects a connection from WinSCP. So, I started sshd on the LiveCD. However, WinSCP was still timing out on the connection. I looked at the Firewall settings on the Full install and noticed that there was a rule to allow sshd. When I tried to create a similar rule on the LiveCD, I got this:

When I tried to disable the firewall, I got this:

lleb 09-21-2012 07:54 AM

did you apply the change?

you can also pull up the terminal and switch over to root and run

service iptables stop
service ip6tables stop

those 2 commands should disable the firewall, you might also need to add the IP scheme to the /etc/hosts... ex: if your LAN IP scheme = then you would add:

192.168.1. mylan

to the /etc/hosts and restart ipfilter

service ipfilter restart

Good luck.

tnili 09-21-2012 02:30 PM

Stoppping those services from the command-line did the trick. Thanks for the response.

Here is a summary of what I did to enable WinSCP access in case anyone comes across this thread in the future.

# service iptables stop
# service ip6tables stop
# service sshd start

[Create a new user with a non-blank password.]

WinSCP/SFTP should work now.

The last step was necessary since sshd does not allow blank passwords by default ('PermitEmptyPasswords' in /etc/ssh/sshd_config).

lleb 09-21-2012 03:45 PM

glad that helped. if working please mark as solved.

All times are GMT -5. The time now is 10:27 PM.