LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Did I install GD correctly? (https://www.linuxquestions.org/questions/linux-newbie-8/did-i-install-gd-correctly-169969/)

lexington 04-14-2004 07:54 AM

Did I install GD correctly?
 
The reason I ask is because I am having problems with a script that uses GD and I was told that I may not have GD installed. So I downloaded GD from this link:

http://www.boutell.com/gd/


uploaded the files to my server, ran ./configure - success

ran make - success

ran make install -success

However I am using php info and I do not see any listing about GD being enabled on my system. Can anyone please help? :(

dopefish 04-14-2004 09:25 AM

Try running ldconfig

lexington 04-14-2004 03:57 PM

So log into ssh and type idconfig?

lexington 04-14-2004 07:23 PM

Please anyone?

dopefish 04-15-2004 07:24 AM

ldconfig with an L but not capital. Im assuming you havent restarted your server at all since you made the change or else this will not make a difference.

lexington 04-15-2004 07:55 AM

ok I ran ldconfig and putty paused for about 3 seconds then went to the next line I didnt see it do anything.

dopefish 04-15-2004 08:08 AM

It doesnt show it doing anything, all it does is reloads everything in /etc/ld.so.conf. Sometimes when you install new drivers or something it will add a line to that file and you need to run ldconfig. Check if GD is reckognized now.

lexington 04-15-2004 08:16 AM

Oh ok, I will check now thanks :D

lexington 04-15-2004 08:19 AM

Ok I do not see GD in the phpinof.php, so I suppose I didnt install it correctly?

uploaded the files to my server, ran ./configure - success

ran make - success

ran make install -success

Thats all I had to do? Why wont this work :(

dopefish 04-15-2004 08:23 AM

Ok take a look at this it may help
http://www.boutell.com/gd/phppatch.html

lexington 04-15-2004 09:05 AM

Ok when I log into Cpanel WHT it says php version 4.3.3, is this patch for php 4.3.2? If so it looks like I already have it installed and I am not seeing GD

lexington 04-15-2004 09:14 AM

Man this sucks I dont know why noone knows my my problem and how to fix it I am sure everyone in here has installed GD before.

lexington 04-15-2004 11:13 AM

Ok nevermind a friend did it for me it works now

dopefish 04-15-2004 12:02 PM

Could you post the solution in case other people come across this problem?

lexington 04-15-2004 12:03 PM

I really dont know what he did, he said that he recompiled PHP that is all I know.


All times are GMT -5. The time now is 06:27 AM.