Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 10-14-2003, 03:12 PM   #1
Registered: Aug 2003
Posts: 36

Rep: Reputation: 15
DHCPd problems (config file is OK) PLZ HELP!

When I type "/usr/sbin/dhcpd start" I get this error message

Internet Software Consortium DHCP Server V3.0.1rc12
Copyright 1995-2003 Internet Software Consortium.
All rights reserved.
For info, please visit
Wrote 0 leases to leases file.
No subnet declaration for start (
** Ignoring requests on start. If this is not what
you want, please write a subnet declaration
in your dhcpd.conf file for the network segment
to which interface start is attached. **
Not configured to listen on any interfaces!
If you did not get this software from, please
get the latest from and install that before
requesting help.
If you did get this software from and have not
yet read the README, please read it before requesting help.
If you intend to request help from the
mailing list, please read the section on the README about
submitting bug reports and requests for help.
please do not under any circumstances send requests for
help directly to the authors of this software - please
send them to the appropriate mailing list as described in
the README file.

When I type "/usr/sbin/dhcpd eth0" the DHCP daemon starts good (haven't tested it yet). But I want it to work 'normally'. I'm using Debian Woody.

This is my dhcpd.conf file
default-lease-time 6000;
max-lease-time 720000;
option subnet-mask;
option broadcast-address;
#option routers;
#option domain-name-servers,;
#option domain-name "";
ddns-update-style ad-hoc;
subnet netmask {

Last edited by SWAT; 10-15-2003 at 04:23 AM.
Old 10-15-2003, 04:02 AM   #2
Registered: Aug 2003
Posts: 36

Original Poster
Rep: Reputation: 15
What I forgot to add is that when I type "/usr/sbin/dhcpd eth0" the daemon starts, but I can't stop it with "/usr/sbin/dhcpd stop"
I just want my DHCPd working with the 'normal' start and stop commands.

Please help!!!!!!!!!!!!!!!
Old 11-11-2003, 04:22 AM   #3
Registered: Aug 2003
Posts: 36

Original Poster
Rep: Reputation: 15
I have a eth0 and a ppp0


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
RedHat: dhcpd.conf - error: Not configured to listen on any interfaces! alinuxLQ Linux - Networking 8 11-05-2015 07:00 PM
dhcpd subnet declaration problems in dhcpd.conf vcrispo Linux - Networking 6 07-15-2005 11:32 AM
dhcpd.conf nsk078 Linux - Wireless Networking 2 07-15-2004 08:53 PM
dhcp.conf or dhcpd.conf? rogerbennett Linux - Networking 3 09-03-2003 01:25 PM
dhcpd.master or dhcpd.conf rickg Linux - Networking 0 04-11-2002 04:34 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:20 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration