LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-13-2004, 04:03 PM   #1
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Rep: Reputation: 15
DHCP Internet Help


I'm going to try to give as much information as possible for this.. please... please try your best for an answer, I'm stumped and I've been playing with it slowly progressing for a long time....

I have a Encore Ethernet card, it is running off of the sis900 module. It successfully loads. It shows up in ifconfig after i type
Code:
ifconfig eth0 up
WITHOUT a ipaddr or any of that. That entire line is out. HOWEVER, in KDE Information Center, the only network interface shown is the loopback.

If I execute
Code:
dhclient
then it tells me No bbroadcast interfaces found - exiting
Code:
dhclient eth0
tells me eth0: not found
Code:
dhcpcd
does something, but I'm not sure what.. it just sits there and then finishes a minute later with no output, with or without eth0 in the parameters.

netconfig responses:
Hostname: enigx
Domain: enigx.net
Everything else: DHCP

I use kernel: 2.4.22
Distribution is: Slackware

I'll be on for a bit, so I'll reply as quick as possible.

Last edited by EnigmaX; 02-13-2004 at 04:04 PM.
 
Old 02-13-2004, 04:07 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Just run netconfig, tell it to use dhcp, and
then set /etc/rc.d/rc.netdevice to use the
module ...


Cheers,
Tink
 
Old 02-13-2004, 04:18 PM   #3
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Original Poster
Rep: Reputation: 15
[delete this post]

Last edited by EnigmaX; 02-13-2004 at 05:17 PM.
 
Old 02-13-2004, 05:15 PM   #4
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Original Poster
Rep: Reputation: 15
file not found

Did you mean me to change something in what you said?

SOMEONE PLEASE HELP ME.. ...This shouldn't be this hard to tag an ip addy to something using dhcp -_-
 
Old 02-13-2004, 05:32 PM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Which file was not found?

Cheers,
Tink
 
Old 02-13-2004, 05:34 PM   #6
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Original Poster
Rep: Reputation: 15
/etc/rc.d/rc.netdevice
 
Old 02-14-2004, 03:28 PM   #7
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
I don't know 9.1 well enough to be certain.
Maybe you don't need rc.netdevice... is the
module being loaded by hotplug while you
boot?


Cheers,
Tink
 
Old 02-14-2004, 03:40 PM   #8
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Original Poster
Rep: Reputation: 15
I figured out the problem.. For some reason my machine is giving out two eth cards, one works, while the other doesn't and is non-existant, and is the default eth0... :/

Thanks for the help..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't connect to the Internet with DHCP 1kyle Linux - Networking 3 11-17-2004 04:09 AM
internet through dhcp? trscookie Linux - Networking 14 11-02-2004 08:13 AM
internet connection with dhcp pelgrimforever Linux - Networking 4 09-03-2004 03:07 PM
DHCP Internet :) gamehack Linux - Networking 0 02-17-2004 07:35 AM
Internet through DHCP gamehack Slackware 4 06-17-2003 06:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration