LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   device tree node failed to get resource (https://www.linuxquestions.org/questions/linux-newbie-8/device-tree-node-failed-to-get-resource-4175612672/)

vivek thullimalli 08-26-2017 01:38 PM

device tree node failed to get resource
 
Hi,

I am working on kernel porting (version Raspberry PI B+-4.9)for custom SoC(with arm1176jzfs core) & Custom Evaluation board. I have written a simple DTS file, to initialize uarts in my board. uart's are physically mapped to 0x5800_0000 & 0x5800_1000 on memory map.
my DTS file:
-----------
[I]aliases {
serial0 = &uart0;
serial1 = &uart1;
};

soc {
compatible = "simple-bus";
#address-cells = <1>;
#size-cells = <1>;

uart0: serial@58000000 {
status = "okay";
compatible = "arm,pl011", "arm,primecell";
reg = <0x58000000 0x1000>;
clocks = <100000000>;
clock-names = "uartclk", "apb_pclk";
arm,primecell-periphid = <0x00041011>;
};
uart1: serial@58001000 {
status = "okay";
compatible = "arm,pl011", "arm,primecell";
reg = <0x58001000 0x1000>;
clocks = <100000000>;
clock-names = "uartclk", "apb_pclk";
arm,primecell-periphid = <0x00041011>;
};
};

During the time of booting it is shown up as:

[ 0.000000] Serial: AMBA PL011 UART driver
[ 0.000000] OF: checking for dev: soc
[ 0.000000] OF: checking for dev: serial
[ 0.000000]
[ 0.000000] OF: amba: of_address_to_resource() failed (-22) for /soc/serial@58000000
[ 0.000000] OF: amba: of_address_to_resource() failed (-22) for /soc/serial@58001000

Any suggestion on the issue?

Thanks,
Vivek. T


All times are GMT -5. The time now is 03:27 PM.