-   Linux - Newbie (
-   -   Deploying web based "information center"- 'Fail to connect Error' (

GwenE 03-23-2009 03:20 AM

Deploying web based "information center"- 'Fail to connect Error'
I want to deploy an Eclipse standalone "InfoCenter". I don't use Eclipse, but I am a technical writer with some rudimentary Linux experience.

When I researched nice, slick and simple online Help systems that follow standards, the Eclipse system stood out. In fact I even found an IBM site where I could download, install and launch this system:

The help system code is a collection of Java Server Pages and servlets, along with an embedded Web application server, a search engine, and the Eclipse run-time environment.

I obtained a 'cloud hosted' Linux server--RHEL 5.1 64 bit, with Apache 2.2.
I can SSH into the 'box' as root. I have installed this 'InfoCenter server' in:

I launched the InfoCenter server, editing the start command (within a shell script) to use port 8081.

I believe the InfoCenter server is running because I can see 2 java processes that weren't there before I launched it... and see it listening to port 8081:

command line output below

# ps -a
  PID TTY          TIME CMD
17133 pts/1    00:00:00 ps
17943 pts/0    00:00:00 bash
17944 pts/0    00:00:00 java
17955 pts/0    00:00:01 java

# /usr/sbin/lsof -i :8081
java    17955 root  33u  IPv6 262880      TCP *:tproxy (LISTEN)

# netstat -nlp | grep ::8081
tcp        0      0 :::8081        :::*      LISTEN      17955/java

However, when I go to http://mysite_ipaddress:8081 in Firefox it churns for a bit then displays a
'Failed To connect' Error: “Though the site seems valid, the browser was unable to establish a connection.”

In Opera it gives: 'Error! Connection closed by remote server'

Being so new to this whole thing... I also tried a few more things to no avail:
A more specific URL (from the instructions I have read I *think* this should at least do something) but got the same result.

To try to rule out incompatibility (the IBM package download recommends Linux 32 not 64), I installed a different java runtime for this system
(jre-6u12-linux-i586.bin) and ran the InfoCenter using that java instead of the IBM-included jre with the 'InfoCenter download." Same results (as expected).

My linux cloud hosted 'server' does work-- it displays the apache default page if I go to http:// mysite_ipaddress (no port reference) or if I specify port 80. It's just that most other port specifications display the 'Fail to Connect Error'
Thanks for any suggestions you can provide :)

GwenE 03-23-2009 05:16 PM

Needed to Edit "iptables" to permit Connection
Hi there. I got it to work. Little did I understand the Linux Firewall issues.... but I'm getting there.

Simply edit the /etc/sysconfig/iptables file, and add in the following line somewhere before the line that says "COMMIT."


-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 8081 -j ACCEPT
After saving the edited file, close it and restart the firewall:

# /etc/init.d/iptables restart

This is explained well at

The thing that confused me as a newbie was the title of the above page:
"How to: Allow telnet and ssh through iptables under Linux"

I knew I didn't need a new telnet or ssh connection, but they all fall under tcp connections I suppose. So it's all done similarly... so my connection problem is resolved and the IBM version of the Eclipse standalone Information Center looks great! To link to it on your system after you install it: http://yoursite_ipnumber/help/index.jsp

All times are GMT -5. The time now is 01:24 PM.