-   Linux - Newbie (
-   -   Dell Studio 1535 Screen Resolution Issue (

Darkon1365 08-04-2010 05:29 PM

Dell Studio 1535 Screen Resolution Issue
Unfortunately my experience in the Unix* based world up to this point has only been using web servers and administrating them, no GUI experience of any kind so I am completely unfamiliar with the setup and entire usage of Xorg or any other Window manager at this point.

The issue I am having is with the screen resolutions I am being allowed to chose for my Dell Studio 1535 running Fedora Core 13 and the KDE 4 desktop GUI, thus my issue since I am not really familiar with how to run a Unix* based GUI in the first place.

The basic information, if there is more needed just advise what and what command gathers that info (or what conf/log I should look into in order to find it).

Laptop is a Dell Studio 1535
Video is the Mobile Intel GMA X3100 ATI Radeon HD 3200 Graphics. LCD interface is the LVDS.

So far it seems to give me modes for 1024x768 and on down, nothing above this. I believe I am supposed to use the radeon driver being that is the type of card it is but every time I change the xorg.conf file to use this instead of vesa the system wont get past the loading screen anymore upon reboot and nor can I seem to find a way to bring up a command line so I can hit up the Xorg.0.log to see what is wrong or change the xorg.conf file back to the original driver it had listed. I am going to assume this is a missing driver or something else it hangs on but without being able to get access back to the system and having to rebuild it again (re-install via live CD) I am basically out of luck at this time. Sorry for the rather poor post but I do hope to receive some basic directions on where to go from here with this issue, thank you for your time and effort as any spent towards helping me solve my issue is greatly appreciated.

Peacedog 08-04-2010 07:28 PM

Hi Darkon1365, Welcome to LQ. Please post the output from the following so we can see which of the two video cards you've listed is actually in the machine.


$ /sbin/lspci -v | grep VGA
Good luck. ;-)

Darkon1365 08-04-2010 10:38 PM

Ok so now this seems a little off from what I was reading but here it is which may be why I ran into issues earlier.


00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03) (prog-if 00 [VGA controller])
I do apologize ahead of time if I made any incorrect assumptions on exactly what card I actually had installed compared to what there really is there.

Peacedog 08-05-2010 03:17 AM

No worries Mate. That's the purpose for the tools we have available to diagnose such things. Now that we know what card we're dealing with, we should be able to sort this.

Does the display funtion properly at the given resolution?

Good luck. ;-)

Darkon1365 08-05-2010 10:34 AM

Yes, it functions at the display's that it offers which are unfortunately limited at this point, 1024x768, 800x600 and 600x400 setting. I went ahead and setup a FC 13 Live CD instead of trying to do my own installation from the source being since that is not really something I am too solid on in the first place and this gave me the extra resolution setting of 1200x800 which is much better though still not the same as my old favorite of 1440x900 which is what I am shooting for.

More so or less I really would like to get more into the QUI side of the Unix* based systems and chose FC as it normally is on the "bleeding" edge of technology when it comes to Unix* based OS's and seems to make a great desktop OS overall. I have my desktop for my gaming and such that will stay as Windows accordingly till at least at one point I can figure out how to get wine (totally different topic for me down the road, one step at a time here for me :)) working properly. So with getting the Live CD installation done instead I did get a step closer to my desired screen resolution, I ran out of time before heading in to work so I did not get a chance to really see if this changed how the xorg.conf is setup or even if it is using xorg as the primary window manager until I can get home and really dig into it again to see what is different that got me the higher screen resolution that is closer to what I am looking for finally.

Darkon1365 08-05-2010 06:14 PM

Just a little update. I am not so much looking for the answer as I am looking for how you got the answer and how to apply it. I would like to be able to become more self sufficient at this time.

Peacedog 08-05-2010 06:30 PM

You can start with the Guide for your choice of Distribution.

There is display/xorg debug specific information here.

Good luck. ;-)

Darkon1365 08-05-2010 09:36 PM

Thank you, the second one is the one that I could not find initially. Going over the docs previously did not really show me anything but I will check the FC docs again (I very well may have missed the appropriate sections or simply not understood the first time through).

Peacedog 08-05-2010 09:50 PM

You're welcome. Just post back for anymore help.

Good luck. ;-)

Darkon1365 08-07-2010 12:50 PM

Unfortunately I am having no luck at all at this point. I am positive it is simply because I don't understand but since I can't seem to find some one that is willing to help me to the point of me actually understanding I seem to be pretty much out of luck period now. I went ahead and redid my installation again and once again I am stuck with a 1024x768 resolution which is not acceptable unfortunately and it just seems there is nothing I am going to be able to do about it unfortunately.

If anyone is feeling kind enough that knows exactly (not just a general look here or there) what I need to do to get this fixed I would greatly appreciate the help. A little information on how you come to the working conclusion as well would be nice so hopefully I can fix this on my own in the future, but for now as it stands I simply can not fix this on my own unfortunately and am at the point that I am just waiting for a helping hand to actually help me get this fixed. So far nothing I am reading in the docs or in the guide provided above is helping. I do not see an actual error in the /var/log/Xorg.0.log unfortunately beyond the stuff below which has not lead me to a single useful piece of info since what ever I add to the xorg.conf does no change the options in the way I am hoping (they add a even smaller resolution to the list instead of a higher one).

[ 22.438] (==) No Layout section. Using the first Screen section.
[ 22.438] (==) No screen section available. Using defaults.
[ 22.438] (**) |-->Screen "Default Screen Section" (0)
[ 22.438] (**) | |-->Monitor "<default monitor>"
[ 22.438] (==) No device specified for screen "Default Screen Section".
Using the first device section listed.
[ 22.438] (**) | |-->Device "Videocard0"
[ 22.438] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.

Darkon1365 08-07-2010 01:05 PM

Ok, the below may actual be useful as well. I unfortunately simply do not understand it but I do feel it likely has something to do with the issue at this time. I just don't know enough on how GUI's work in the Unix world to take this info and fix my issue.

[ 22.551] (II) VESA(0): Printing DDC gathered Modelines:
[ 22.551] (II) VESA(0): Modeline "1280x800"x0.0 66.09 1280 1304 1328 1352 800 803 809 816 +hsync -vsync (48.9 kHz)
[ 22.551] (II) VESA(0): Searching for matching VESA mode(s):

[ 22.574] (II) VESA(0): Total Memory: 119 64KB banks (7616kB)
[ 22.574] (II) VESA(0): <default monitor>: Using hsync value of 48.88 kHz
[ 22.574] (II) VESA(0): <default monitor>: Using vrefresh value of 59.91 Hz
[ 22.574] (WW) VESA(0): Unable to estimate virtual size
[ 22.574] (II) VESA(0): Not using built-in mode "1024x768" (no mode of this name)
[ 22.574] (II) VESA(0): Not using built-in mode "800x600" (no mode of this name)
[ 22.574] (II) VESA(0): Not using built-in mode "640x480" (no mode of this name)
[ 22.574] (WW) VESA(0): No valid modes left. Trying less strict filter...
[ 22.574] (II) VESA(0): <default monitor>: Using hsync value of 48.88 kHz
[ 22.574] (II) VESA(0): <default monitor>: Using vrefresh value of 59.91 Hz
[ 22.574] (WW) VESA(0): Unable to estimate virtual size
[ 22.574] (II) VESA(0): Not using built-in mode "1024x768" (hsync out of range)
[ 22.574] (II) VESA(0): Not using built-in mode "800x600" (hsync out of range)
[ 22.574] (II) VESA(0): Not using built-in mode "640x480" (hsync out of range)
[ 22.574] (WW) VESA(0): No valid modes left. Trying aggressive sync range...
[ 22.574] (II) VESA(0): <default monitor>: Using hsync range of 31.50-48.88 kHz
[ 22.574] (II) VESA(0): <default monitor>: Using vrefresh range of 50.00-59.91 Hz
[ 22.574] (WW) VESA(0): Unable to estimate virtual size
[ 22.574] (II) VESA(0): Not using built-in mode "640x480" (hsync out of range)
[ 22.574] (--) VESA(0): Virtual size is 1024x768 (pitch 1024)
[ 22.574] (**) VESA(0): *Built-in mode "1024x768"
[ 22.574] (**) VESA(0): *Built-in mode "800x600"
[ 22.574] (**) VESA(0): Display dimensions: (330, 210) mm
[ 22.574] (**) VESA(0): DPI set to (78, 92)
[ 22.574] (II) VESA(0): Attempting to use 60Hz refresh for mode "1024x768" (118)
[ 22.576] (II) VESA(0): Attempting to use 60Hz refresh for mode "800x600" (115)

So as far as I can tell this is telling me it simply can't find a valid mode for my screen even though one does exist. Is this an issue with the VESA driver and if so how do I fix it without killing my system? Since last time I tried switching drivers I ended up having to reformat as I could not even get a command line to come up (no idea how to get to one if it won't get past the Fedora Loading screen) to undo my last changes.

Darkon1365 08-07-2010 03:17 PM

Ok after reformatting yet again as I just did it again lol. Unfortunately I can't seem to properly modify the xorg.conf and end up killing my system each time and I am unable to get to a command line (most likely don't know how) so I have to reformat each time. I went ahead with the FC 13 Live CD (KDE version) and this gets me at least 1280x800 so I am happy with this. Still if anyone wants to fill me in on how to make sure I can get back to the command line even if I completely blow away my windows manager (Xorg at this time) I would greatly appreciate. That way I can go ahead and continue to try to fix this on and off and just recover my backup xorg.conf file when I blow it. Thanks again for any help any of you have provided, it has been greatly appreciated.

Peacedog 08-07-2010 10:02 PM

To get back to the cli, use ctl+alt+backspace. That should kill the x-session. Concerning setting up the xorg file, you probably just need to specify the proper driver, which in your case should be intel iirc. The 1280 x 800 may be a driver limitation. Hope that clears up a few things, it wasn't my intention to be short with my earlier posts.

Good luck. ;-)

All times are GMT -5. The time now is 01:31 PM.