LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Dell 64Mb USB KeyChain (https://www.linuxquestions.org/questions/linux-newbie-8/dell-64mb-usb-keychain-87733/)

robert_81 08-31-2003 06:27 PM

Dell 64Mb USB KeyChain
 
Hi I got a Dell 64Mb USB keychain. I got linux Mandrake 9.1 and connected the keychain. How can i access the data that;s on the key chain please? I really have no idea i went to check under /dev/usb but no items are there :\

KneeLess 08-31-2003 07:19 PM

For some reason (that I don't understand) numerous sources say that you need to mount it as a SCSI device.

You can try:
Code:

mount -t /dev/sda1 /mnt/usb
Not sure if that'll work.

Here's another thread on this topic:
http://www.linuxquestions.org/questi...003/08/3/80226

m_yates 08-31-2003 11:04 PM

For Mandrake 9.1 using KDE, it should work automatically. When you plug the drive in, wait a few seconds and you should see an icon for the drive appear on the desktop. It is not mounted, but if you right click the icon and select mount, you should be able to do it (even as a regular user) and access files by double clicking the icon. The directory it is mounted at is /mnt/removable and the "removable" directory is created automatically. The drive is a SCSI device as mentioned above. It is normally /dev/sda1.

Zb7 09-01-2003 12:01 AM

Quote:

Originally posted by KneeLess
For some reason (that I don't understand) numerous sources say that you need to mount it as a SCSI device.

You can try:
Code:

mount -t /dev/sda1 /mnt/usb
Not sure if that'll work.

Here's another thread on this topic:
http://www.linuxquestions.org/questi...003/08/3/80226


It should. I have a Dell 64 meg flash and I mount it with that exact command.

This is just a backup opinion and I see no reason why that command shouldn't work.

robert_81 09-03-2003 04:55 PM

Hi Guys I managed to mount the usb key chain though with this command mount /dev/sda1 /mnt/usb (without the -t). Each time I try to use the -t option I get the help of mount command which means it didn't work :\ I am able to see the files but under root only. Does the -t have to do with any permissions? Also I tried giving 777 permissions on the /mnt/ directory via mandrake control centre/security but still no luck. With root i am able to see the files but with user I have access denied on such files, any idea guys? Thanks very much in advance for your precious help :)

m_yates 09-03-2003 05:01 PM

The -t stands for "type" as is filesystem type. I think it would work if you typed:

mount -t vfat /dev/sda1 /mnt/usb

That is for the FAT filesystem, but I guess you don't need to indicate the type.

I'm surprised that you need to issue any command though. I use Mandrake 9.1 and it works automatically in KDE.

robert_81 09-03-2003 05:09 PM

I use gnome not KDE maybe it makes a difference :\ Well I tried this and it is telling me /mnt/usb is already mounted or perhaps busy. How can I unmount it first so that I can mount it again in vfat file system? Thanks

m_yates 09-03-2003 05:12 PM

The command for unmounting is:

umount /dev/sda1

It is "umount" not "unmount" . Make sure you don't have anything accessing it. You can't be in the /mnt/usb directory when you unmount and you can't have nautalis(sp?) open to the /mnt/usb directory.

robert_81 09-03-2003 05:28 PM

Hi I mounted the device successfully as vfat but still, when i access it with nautalis the files dissapear, meaning that access is denied. Also this time the usb folder came up with the icon pencil crossed, which means no writing access. I want it read write access with the current user i am logged on :\ any ideas what it could be?

m_yates 09-03-2003 05:36 PM

Did you happen to look and see if you have a directory called /mnt/removable? If I remember correctly, Mandrake automatically created that directory when I plugged in a usb drive and created a link to it. Perhaps there is a problem having /mnt/usb and whatever Mandrake does automatically.

robert_81 09-03-2003 05:46 PM

Yes there is a directory /mnt/removable and in fact when i mount the key chain on that folder a link from the desktop is created automatically, but still with access denied :\ This is driving me mad :\

m_yates 09-03-2003 06:15 PM

OK, I think I have found the solution. Mount the drive using:

mount /dev/sda1 /mnt/removable

You have to be root (no -t needed). I just did this manually on my system from the Fluxbox window manager (so it should not be KDE-specific). I was able to read and write to the /mnt/removable directory as root.

Azmeen 09-03-2003 09:53 PM

Quote:

Originally posted by robert_81
Yes there is a directory /mnt/removable and in fact when i mount the key chain on that folder a link from the desktop is created automatically, but still with access denied :\ This is driving me mad :\
As root, edit your /etc/fstab file and look for a line containing /mnt/removable.

Somewhere at the end of the line, you will see some settings similar to: owner,ro,noauto

What you have to do is: if there is a owner defined there, change it to user, and if ro is defined change it to rw.

You should now have read and write access to /mnt/removable as root or user.

robert_81 09-04-2003 07:48 PM

Hi Guys,
Very bad news :\ i always mounted the usb keychain in root user (from shell) though i access the files as a user from the gui.. also Azmen, i am the owner of that check this line, what can i change from it please?

/dev/sda1 /mnt/removable auto user,iocharset=iso8859-15,kudzu,codepage=850,noauto,umask=0,exec 0 0

I'm so lost and cannot find any answer for this USB issue :\ with windows it just works there and then :\ I want it to work on Linux though :\ Any more ideas please?

Azmeen 09-04-2003 08:11 PM

Quote:

Originally posted by robert_81
Hi Guys,
Very bad news :\ i always mounted the usb keychain in root user (from shell) though i access the files as a user from the gui.. also Azmen, i am the owner of that check this line, what can i change from it please?

/dev/sda1 /mnt/removable auto user,iocharset=iso8859-15,kudzu,codepage=850,noauto,umask=0,exec 0 0

I'm so lost and cannot find any answer for this USB issue :\ with windows it just works there and then :\ I want it to work on Linux though :\ Any more ideas please?

Change it to:

Code:

/dev/sda1    /mnt/removable        auto        user,noauto,rw    0  0
And you're done!


All times are GMT -5. The time now is 09:36 AM.