LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-09-2010, 07:17 AM   #1
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Rep: Reputation: 30
Delivery Status Notification (Failure)


OMG, something went wrong with my email notifications in nagios.
Just when i thought i have successfully set it up..
Suddenly, just so suddenly it failed. x_x
HELP.

I got the mail below:

Code:
Delivery to the following recipient failed permanently:

    root@server.com

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 550 550 #5.1.0 Address rejected root@server.com (state 14).

----- Original message -----

Received: by 10.114.109.1 with SMTP id h1mr16785732wac.203.1281263841711;
       Sun, 08 Aug 2010 03:37:21 -0700 (PDT)
Return-Path: <layleng91@gmail.com>
Received: from ubuntu (bb119-74-182-12.singnet.com.sg [119.74.182.12])
       by mx.google.com with ESMTPS id s5sm7619999wak.12.2010.08.08.03.37.19
       (version=TLSv1/SSLv3 cipher=RC4-MD5);
       Sun, 08 Aug 2010 03:37:21 -0700 (PDT)
Received: by ubuntu (Postfix, from userid 0)
       id 15A0B40A6B; Sun,  8 Aug 2010 18:37:06 +0800 (SGT)
From: Anacron <xanios@gmail.com>
To: root@server.com
Subject: Anacron job 'cron.daily' on ubuntu
Message-Id: <20100808103707.15A0B40A6B@ubuntu>
Date: Sun,  8 Aug 2010 18:37:06 +0800 (SGT)

/etc/cron.daily/logrotate:
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName

Do refer to my previous threads regarding me setting up of the email notifications.. Thanks..
 
Old 08-09-2010, 08:16 AM   #2
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,375

Rep: Reputation: 217Reputation: 217Reputation: 217
Sounds to me like a DNS problem and potentially not even your end, do you get similar problems with other domains/e-mail addresses.
 
Old 08-09-2010, 09:00 AM   #3
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
If you are relaying email using Gmail smtp server and sending to your internal mail account that you have setup on your internal mail server, it wont ever be relayed. How would gmail smtp know of your internal server when there is no proper DNS record set for it?
Send your notification to your gmail account and it should work.
 
Old 08-09-2010, 09:08 AM   #4
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
Hi r3sistance,

I just created a new gmail account and used that account to receive mails, and that was no problem. I'm able to receive mails. I wonder whats wrong with my previous email account. It was able to receive mails from 7th of august until yesterday. ):

Last edited by Xanios; 08-09-2010 at 09:10 AM.
 
Old 08-09-2010, 09:10 AM   #5
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by linuxlover.chaitanya View Post
If you are relaying email using Gmail smtp server and sending to your internal mail account that you have setup on your internal mail server, it wont ever be relayed. How would gmail smtp know of your internal server when there is no proper DNS record set for it?
Send your notification to your gmail account and it should work.
Hi Chaitanya,

Sounds a little confusing, sorry >.<

What you mean by send my notification to my gmail account?

Last edited by Xanios; 08-09-2010 at 09:11 AM.
 
Old 08-09-2010, 09:14 AM   #6
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Read your previous post. That is what I meant. You would not be able to receive mails on root@server, which is your internal address. This is because you are using Gmail as relay. Gmail would not know about your internal server as you do not have DNS set up properly. But you can send to gmail address as gmail SMTP would be able to resolve it.
 
Old 08-09-2010, 09:18 AM   #7
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,375

Rep: Reputation: 217Reputation: 217Reputation: 217
Ah, can't believe I missed that one. root@server, should have soon that one, guess I skimmed that part in error.
 
Old 08-09-2010, 09:21 AM   #8
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by linuxlover.chaitanya View Post
Read your previous post. That is what I meant. You would not be able to receive mails on root@server, which is your internal address. This is because you are using Gmail as relay. Gmail would not know about your internal server as you do not have DNS set up properly. But you can send to gmail address as gmail SMTP would be able to resolve it.
Hi,

So you're saying i'm sending mails to my root@server? But, how could that be? I mean, i've defined the gmail address that i want email notifications to send to, where did that root@server popped out. x_x
 
Old 08-09-2010, 09:24 AM   #9
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 6/7
Posts: 1,375

Rep: Reputation: 217Reputation: 217Reputation: 217
Did you configure your server to relay ALL e-mail to gmail? It could be automatic log reports or some other services trying to send information to root.
 
Old 08-09-2010, 09:31 AM   #10
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
No i guess. I only defined my gmail address in sasl_password and in contacts.cfg. What else are there?
 
Old 08-10-2010, 01:08 AM   #11
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
You will need to tell nagios where it needs to send mails to and from which smtp server.
 
Old 08-10-2010, 01:54 AM   #12
Xanios
Member
 
Registered: Jul 2010
Posts: 216

Original Poster
Rep: Reputation: 30
In contacts.cfg right? in define contact..there is a email, i gave my gmail.

Code:
define contact{
        contact_name            nagiosadmin             
        use                     generic-contact         
        alias                   Nagios Admin            
        email                   xanios@gmail.com  
        }
 
Old 08-10-2010, 01:57 AM   #13
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
I do not know how to do that.
 
Old 08-10-2010, 02:03 AM   #14
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hi Xanios,

It looks to me that this mail is a system mail that's being sent from a deamon (cron) to the root user on your server. Since you're relaying ALL your mail to GMail you're getting this error because GMail cannot resolve your domain/host. Normally the simplest way is to create a file named .forward in your root's home directory (and maybe also in your user home directory) containing your destination email address. Like this:
Code:
root@srvnagios:~# cat .forward
user@gmail.com

root@srvnagios:~#
Not sure if you should restart postfix but it wouldn't hurt. With this 'forward' file all mails to the root user will be automagically forwarded to your gmail address.

Kind regards,

Eric
 
Old 08-10-2010, 02:05 AM   #15
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Quote:
Originally Posted by Xanios View Post
In contacts.cfg right? in define contact..there is a email, i gave my gmail.

Code:
define contact{
        contact_name            nagiosadmin             
        use                     generic-contact         
        alias                   Nagios Admin            
        email                   xanios@gmail.com  
        }
Hi Xanios,

Look at the mail you posted. It's not from Nagios!
Code:
From: Anacron <xanios@gmail.com>
To: root@server.com
Subject: Anacron job 'cron.daily' on ubuntu
Message-Id: <20100808103707.15A0B40A6B@ubuntu>
Date: Sun,  8 Aug 2010 18:37:06 +0800 (SGT)

/etc/cron.daily/logrotate:
Read my previous post and try that. If your postfix was working before then this should do the trick for your system messages.

Kind regards,

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Delivery status notification from Cron. glore2002 Debian 4 10-12-2009 06:43 PM
Delivery status notification- Using Postfix 2.2.7 on Clarkconnect Enterprise 4.2 cgreen6911 Linux - Enterprise 0 03-26-2009 05:39 PM
How to disable delivery status notification courier sci3ntist Linux - Server 0 01-15-2008 07:35 AM
delivery failure notification pansarevaibhav Linux - Newbie 1 12-16-2006 04:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration