Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-26-2014, 08:51 AM   #1
Registered: Aug 2012
Posts: 709

Rep: Reputation: Disabled
Default SSL/443 Webserver for Apache

/etc/httpd/conf/httpd.conf has three sections: Global, Main Server Configuration, and Virtual Servers. When a Virtual Server is created, it will default to the Main Server Configuration.

Thinking this same patter would continue, I put "<VirtualHost *:443>bla bla bla</VirtualHost>" in /etc/httpd/conf/httpd.conf, but got the following error:
[root@michaels httpd]# service httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: [Tue Mar 25 22:28:23 2014] [warn] _default_ VirtualHost overlap on port 443, the first has precedence
[root@michaels httpd]#
Looking in /etc/httpd/conf.d/ssl.conf, sure enough I see "<VirtualHost _default_:443>bla bla bla </VirtualHost>".

How do I resolve this error? I would rather not comment out the default VirtualHost in ssl.conf, but extend the default values to any newly created SSL VirtualHost.

Old 03-26-2014, 10:36 AM   #2
Registered: Aug 2012
Posts: 709

Original Poster
Rep: Reputation: Disabled
Yikes!!! I am definitely doing something wrong. I added "NameVirtualHost *:443" in /etc/httpd/conf/httpd.conf, and now starting httpd fails, and I don't even show any errors in /var/log/httpd/error_log.

EDIT. Nevermind about the no errors in error_log. I was logging them somewhere else. Original questions in first post remain.

Last edited by NotionCommotion; 03-26-2014 at 10:40 AM. Reason: Error log bit
Old 03-26-2014, 11:08 AM   #3
Registered: Aug 2012
Posts: 709

Original Poster
Rep: Reputation: Disabled
After resolving the problem with logs being logged elsewhere, I discovered that I did not include SSLEngine on in the VirtualHost.

That being said, I have everything working, but still question how the VirtualHost uses the Main Server default settings.

The only way I could get things working is to also put these in the 443 VirtualHost defined in /etc/httpd/conf/httpd.conf. But I also put them in /etc/httpd/conf.d/ssl.conf includes the key and certificate. What is the point of putting them in ssl.conf? Is this only if your are not using name servers? That seems to make sense. One key/cert for each domain name, right? If that is the case, however, should I even be using the ssl.conf file? Or should I use it to define VirtualHosts for 443?

Thank you


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Set up a SSL secured Centos/Apache webserver NotionCommotion Linux - Newbie 6 03-19-2014 12:04 PM
Apache 2.2 won't default to SSL Ixalmida Linux - Server 5 05-12-2010 04:54 PM
Sharing https 443 port for apache ssl and ssh server nx5000 Linux - Software 8 09-02-2009 06:19 AM
Apache-ssl not working on 443.. rjcrews Debian 0 05-03-2006 01:37 PM
what is the webserver's (apache) default user/group on SuSe MaestroC SUSE / openSUSE 1 09-09-2005 01:15 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:39 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration