LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Default gateway and ip, won't stay. SuSe9.1 2.6.5-7.201 (https://www.linuxquestions.org/questions/linux-newbie-8/default-gateway-and-ip-wont-stay-suse9-1-2-6-5-7-201-a-364876/)

yoinker 09-19-2005 10:51 AM

Default gateway and ip, won't stay. SuSe9.1 2.6.5-7.201
 
Hi all

As the title says, every time I restart the box, I have to give my wireless nic an IP, and set the default gateway, its set to get the ip through DHCP, and my router is set aswell. My network uses 192.168, everything else on the network gets its ip from the router. I use static ips on my network, but this box still doesn't pick it up from the router, once I give this box an ip using ifconfig eth1 <ip address> and set the default gateway using route add default gw <routers ip address> everything works fine, until I reboot.

Does anyone know why this happens, or what I can do to rectify the problem. Any help would be greatly appreciated.

Thanks all


Yoinker

Peacedog 09-20-2005 08:00 PM

Hi yoinker, welcome to lq.

There may be something to help you here.

http://www.novell.com/documentation/...l/ch14s03.html

good luck.

yoinker 09-21-2005 12:58 PM

Hi peacedog

Thank you very much for the link, after reading through it I created a file called ifcfg-eth-id-<wlan mac addy> in /etc/sysconfig/network. After re-booting, I could connect to my network but not outside, without using route add default gw. I searched some more and found a thread on this site with a problem similar to mine, basically, I have an onboard network card, which I havn't configured, and SuSe was trying to configure this, as this is on eth0, when it was unable to get an ip for this it ignored the wlan request, so I promptly disabled the onboard nic, and hey presto, all is in order. I think I can now go and delete the file fcfg-eth-id-<wlan mac addy> in /etc/sysconfig/network, as its a usb wlan card, and reading more I believe its configured by the ifcfg-wlan-bus-usb file in /etc/sysconfig/network, which is there .

Thanks again for the link.


Yoinker

Peacedog 09-21-2005 02:55 PM

Your welcome, glad you got it sorted. ;)

good luck.

yoinker 09-21-2005 03:02 PM

Seems I was wrong about deleting the file fcfg-eth-id-<wlan mac addy> in /etc/sysconfig/network, when I did I couldn't connect to anything without ifconfig eth1 <ip address> and route add deafualt gw. So I created the file again, configured it and all is good again.



Yoinker


All times are GMT -5. The time now is 04:49 AM.