-   Linux - Newbie (
-   -   Debian XFCE4 - Synaptic problems (I can't find my programs :( ) (

Stimz 08-21-2005 02:29 AM

Debian XFCE4 - Synaptic problems (I can't find my programs and now my keyboard stops)
Well I've now installed Debian Sarge for the third time this time following the fine advice given to look at
which led me to this awesome website, so if your struggling with Debian look at this. (The only thing I did different was to install XFCE4 instead of windowmaker) XFCE is great....

Anyway I have a problem, I used synaptic to download things like OpenOffice, thats all done now, but I've rebooted several times and still XFCE doesn't load the icons into it's menu.
I can't find the executable files or icons (used to winBLows sorry :( ) to load them up. It's not as if they are not installed as I can use the run command in the XFCE menu and get them running (for the most part).
Have I missed out part of the installation process? What do I need to do? Help! ;)

well things have taken a turn for the worst, I thought it was just a glitch but it just happened again, the keyboard quit working on the laptop (I had to manual restart and get my spare keyboard from the attic, I'm not sure if it will solve the problem) without the keyboard of course I can't get to the command line to see whats going wrong. The computer and keyboard will work fine for about 15-20 mins then it will suddenly cease. Any ideas?


craigevil 08-21-2005 02:55 AM

Your missing OO in the menu? Is that what I understand your saying?

Load Synaptic from a terminal then search for the package called "menu", install it then in a terminal run update-menu. You will now have a Debian menu.

There are a lot of apps I don't have in the menu, I use a cool little app called grun. Click on it and it pops up a run dialog, just enter then name of the app you want to run and poof it runs.

Stimz 08-21-2005 03:11 AM

Yes I am missing OO from my menu, I'm running XFCE4, I am not missing the menu itself but it plain doesn't pick up the new installed software and add them to it.
It turns out I have menu installed, I tried "menu-update" from -run program and in terminal (command unknown) nothing changed, I tried "update-menus" in the same fashion nothing happened.
If synaptic downloaded it, then it will be installed correct?


Stimz 08-21-2005 03:25 AM

Well I think I *might* have found the problem. For anyone else who has this problem. Synaptic - XFCE4 and download all the patches you haven't got... DOH! I will see if it solves the problem.
Thanks Craigevil.

craigevil 08-21-2005 03:48 AM

The last time I looked it didn't quite look like all of the plugins for XFCE were in the testing repository.

When I installed it I used :
# Up-to-date Xfce Debian packages (currently at 4.2.2)
deb testing main
deb-src testing main

All times are GMT -5. The time now is 01:25 AM.