Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-02-2018, 06:17 AM   #1
LQ Newbie
Registered: Apr 2017
Location: UK
Distribution: Custom
Posts: 22

Rep: Reputation: Disabled
Debian stretch Nvidia Issues


Not sure if this would fall under newbie or Debian but here goes...

I've recently installed stretch and have been using it without issue until I install the Nvidia driver. As soon as its installed and i reboot I see grub as normal then on boot I get a message on my monitor osd saying out of range.

GPU is a gtx 1080 on a 1080p60 screen.

Doesn't allow me to switch to another tty so my only route back into the os is via recovery console. Removing the nvidia driver with a purge just results in xorg no longer starting with a no screens found message but does give the console access back.

I've followed the install process listed on the debian wiki for the drivers but no luck. As its a fresh install I've formatted the drive an reinstalled it from scratch a couple of times now always ending in the same result.

Am I missing somthing obvious here? If the monitor is out of range it would suggest a res or refresh rate being set incorrectly and if so how would I set that via the recover console?

I've tried verious suggestions on posts that I've found on google like making sure nouveau is blacklisted, setting the video=lvds in the grub config, creating an xorg.conf with various crap in but still no luck, although most posts Ive found are not debian 9 specific so not sure if that makes a difference.

Any help most appreciated,

Old 03-02-2018, 09:33 AM   #2
LQ Guru
Registered: Nov 2004
Location: Saint Amant, Acadiana
Distribution: Gentoo ~arch
Posts: 6,317

Rep: Reputation: Disabled
I assume by nVidia driver you mean proprietary closed source driver.
There are two parts of driver. The kernel module and the Xorg module. From your description I understand when the kernel module loads the display goes off. Solution would be to pass correct parameters to the kernel module. There should be documentation in /usr/share/ after driver installation and also the same and even more comprehensive documentation can be found online.
Old 03-02-2018, 10:11 AM   #3
LQ Newbie
Registered: Apr 2017
Location: UK
Distribution: Custom
Posts: 22

Original Poster
Rep: Reputation: Disabled
Hi Emerson,

Thanks for the quick reply.

Originally Posted by Emerson View Post
I assume by nVidia driver you mean proprietary closed source driver.
Its the package nvidia-driver from the non-free repo so Im guessing that is the proprietary driver?

Originally Posted by Emerson View Post
Solution would be to pass correct parameters to the kernel module.
Would this be the kernel mode setting? And if so would it just be a case of updating the grub config with GRUB_GFXPAYLOAD_LINUX=1920x1080x32 ?
Old 03-06-2018, 04:05 AM   #4
LQ Guru
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007
You can get to a tty by CTRL-ALT-F1-F4. That way you can install the nVidia driver and work on the machine. Debian uses Xorg X11, so you can edit, or create, xorg.conf. You would need the monitor section of that file spelled out explicitly.

# xorg.conf
Section "Monitor"
HorizSync      15 - 50
VertRefresh    48 - 62
ModeLine "1920x1080" 74.25 1920 2008 2052 2200 1080 1084 1094 1124 +hsync +vsync Interlace
SubSection "Display"
Modes "1600x1200"
End Section
But set Modes to your monitor's native resolution. To get the sync and refresh rates[code]$ sudo X -verbose 6 > testlog.txt[code]and look for horisync and vertrefresh in the testlog file. To get the modeline
$ cvt 1600x1200 60
but feed the cvt command your monitor's native resolution and refresh rate.

Back up your existing xorg.conf, if there is one
$ cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
Put xorg.conf into the /etc/X11/ directory.

To finish off the xorg.conf file
$ nvidia-xconfig
Now try to start the xserver
$ startx &

Last edited by AwesomeMachine; 03-06-2018 at 04:09 AM.


debian 9, debian stretch, nvidia driver

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to install the latest NVIDIA drivers on Debian 9 Stretch Linux LXer Syndicated Linux News 0 02-26-2018 10:20 PM
Stretch Wayland and NVIDIA Support VisionIncision Debian 2 05-04-2017 11:03 AM
Trouble installing Nvidia driver on Debian Stretch kawedel Linux - Hardware 1 10-22-2016 04:47 PM
gtk3 issues under kde (debian stretch) _spectrum_ Linux - Software 3 07-09-2015 07:01 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:44 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration