LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-03-2005, 01:59 PM   #1
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Rep: Reputation: 15
Question Debian Sarge Onboard Graphics Issues


Hello:

I have installed Sarge, but am having difficulties with
the video. The output is pixelated and the only resolution setting
available is 640X480. lspci reports that the graphics card is:
0000:00:01.0 VGA compatible controller: Intel Corp. 82810E DC-133 CGC
[Chipset Graphics Controller] (rev 03). The monitor is an NEC
Multisync II. The refresh rates are set according to monitorworld.com
specs.

The box is a pieced-together-from-scraps machine based around a Compaq
with a 633 MHZ Celeron

Thanks for any assistance...

Roger
 
Old 08-03-2005, 07:46 PM   #2
oot
Member
 
Registered: Dec 2002
Distribution: Slackware 12.0
Posts: 240

Rep: Reputation: 30
It sounds like you haven't set the right module for your video card in your X configuration file... post the "card" section from the file so we can see it?
 
Old 08-03-2005, 08:11 PM   #3
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
Thanks so much for responding. I am a newbie, but I think that this is what you are asking for:

Section "Device"
Identifier "Generic Video Card"
Driver "vga"
VideoRam 256
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 15.5-35
VertRefresh 50-80
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 4
SubSection "Display"
Depth 1
Modes "800x600"
EndSubSection
SubSection "Display"
Depth 4
Modes "800x600"
EndSubSection
SubSection "Display"
Depth 8
Modes "800x600"
EndSubSection
SubSection "Display"
Depth 15
Modes "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "800x600"
EndSubSection
EndSection


Additional info. I did try a different monitor and the problem remained, so I think that there is something wrong with how the os is seeing the onboard graphics.

Last edited by jrcreasy; 08-04-2005 at 08:31 AM.
 
Old 08-04-2005, 08:55 AM   #4
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
I have been told that the problem may be in the bios, that I need to set the video ram to the max. Does this seem like a possibility? I don't want to start screwing around with stuff unless I am relative sure it will make a (positive ) difference.
 
Old 08-04-2005, 03:40 PM   #5
TigerOC
Senior Member
 
Registered: Jan 2003
Location: Devon, UK
Distribution: Debian Etc/kernel 2.6.18-4K7
Posts: 2,380

Rep: Reputation: 49
Resetting the shared memory is no biggy. Get into the bios and you'll probably find the graphics controls in peripherals or under advanced (just have a look around) and set the memory to whatever your system can afford. Bear in mind that it's reserving part of your RAM. You can now reconfigure the X server. Do as root dpkg-reconfigure xserver-xfree86 and when you get to the grahics card section enter the amount of memory you set in the bios and then save the setting.
 
Old 08-04-2005, 04:07 PM   #6
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 9 Stretch
Posts: 2,276
Blog Entries: 8

Rep: Reputation: 361Reputation: 361Reputation: 361Reputation: 361
First, to get more colors you'll need to change your DefaultDepth to 24 (or 16 or 8).

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 4 <----- change to 24
...

Also try changing the "Generic Video Card" section to:

Section "Device"
Identifier "Generic Video Card"
Driver "vga" <----- change to "i810"
VideoRam 256 <----- delete this line
EndSection

So it looks like:

Section "Device"
Identifier "Generic Video Card"
Driver "i810"
EndSection

After making these changes, log out to the login window and restart your X server by pressing Ctrl-Alt-Backspace.

If my guess is wrong and your onboard video is NOT i810, then the X-server will fail to restart and you'll be stuck with a text login prompt. In that case, login (in text mode) and change the video driver to "vesa". You can do this with the commands:

su
vi /etc/X11/XF86Config-4

"su" lets you log in as root, it will ask you for the root password.

vi is a console text editor. The basic vi commands you need to know are:

"i" --- enters "insert mode". You'll want to press "i" once after the program starts to put you into "insert mode".

escape key --- exits "insert mode"

"ZZ" --- saves the file and quits. You need to toggle OFF insert mode in order to enter this command. Otherwise, pressing "ZZ" merely types in ZZ where the cursor is.

":q!" --- quits without saving any changes. Use this if you mess up accidentally.
 
Old 08-04-2005, 09:51 PM   #7
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
Thumbs up SOLVED!

IsaacKuo: You sir are a gentleman, scholar and genius! Your solution solved my problem. However, now the image area is too great vertically for my monitor. The monitor does have a 'V Size' control, which is set to the smallest. I can view everything, but I have to move the image area around on the screen with 'V Posi'. Any suggestions?IsaacKuo: You sir are a gentleman, scholar and genius! Your solution solved my problem. However, now the image area is too great vertically for my monitor. The monitor does have a 'V Size' control, which is set to the smallest. I can view everything, but I have to move the image area around on the screen with 'V Posi'. Any suggestions?
 
Old 08-04-2005, 11:08 PM   #8
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 9 Stretch
Posts: 2,276
Blog Entries: 8

Rep: Reputation: 361Reputation: 361Reputation: 361Reputation: 361
Your monitor may have difficulty fully supporting the attempted resolution/refresh rate. Hmm...

...okay, I just did a google search on NEC Multisync II. Good lord, that's an antique! According to www.monitorworld.com, that monitor's max resolution is 800x600, with a max refresh rate of 80hz.

Your monitor section reflects the correct refresh ranges, and I'll bet the x-server is attempting to max it out at 80hz. Unfortunately, your old monitor possibly can't handle a full 80hz anymore at 800x600 (if it ever could).

Try reducing the vertical refresh range from 50-80 to 50-60. This should start up 800x600x60hz, which hopefully your monitor can handle alright.
 
Old 08-06-2005, 03:34 PM   #9
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
OK. I solved the monitor problem. I moved the NEC to the museum and bought a newer used monitor, which works fine. Thanks for all of the help. Now, on to post my next question....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
printing issues on Debian sarge 3.1 samael26 Debian 6 04-19-2005 02:58 PM
X-Windows fails to start & other Debian sarge install issues tommilo Linux - Newbie 30 03-02-2005 10:49 AM
Graphics issues with Intel 82856G Graphics Adapter herrmag Linux - Newbie 1 08-09-2004 03:52 PM
Couple of issues with Debian "sarge" KRiSX.cjb.net Linux - General 0 07-14-2004 05:35 AM
Sarge Debian and X = issues orange400 Debian 16 06-16-2004 05:39 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration