LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-30-2009, 10:03 PM   #1
foothead
LQ Newbie
 
Registered: May 2009
Posts: 6

Rep: Reputation: 0
debian refresh rate too high


I just managed to get debian to install on my computer (attempt 11 i think) and now I am having a problem where it boots up but right when gnome would start, my screen goes black and my monitor gives a warning that the refresh rate is too high. I did ctrl alt f1 and tried to get to my xorg file but i get permission denied and when i try to use sudo, I get a warning that I am not in the sudoers file. what can I do here? thanks.

EDIT: ok, i logged in as root, but am still getting access denied. Can this even happen? oh yeah, my monitors native resolution is 1366 x 768 @60Hz and my graphics card is a 2gb HD4870 x2.

Last edited by foothead; 11-30-2009 at 10:08 PM.
 
Old 11-30-2009, 10:07 PM   #2
chromei386
Member
 
Registered: Dec 2008
Distribution: Fedora 13
Posts: 30

Rep: Reputation: 15
you need to add yourself as a sudo user.

from another guide, this is how you do it:

[mirandam@charon ~]$ su
Password: <--- Enter root password

[root@charon mirandam]# echo 'mirandam ALL=(ALL) NOPASSWD:ALL' >> /etc/sudoers
[root@charon mirandam]# exit
exit

replace mirandam as your user etc. this does sudo with no password (you can set it will password too see man page).

For now if you don't want to do that you can simply log in as root using su and change the xorg config, then exit out of root
 
Old 11-30-2009, 10:18 PM   #3
foothead
LQ Newbie
 
Registered: May 2009
Posts: 6

Original Poster
Rep: Reputation: 0
I am still getting Permission denied as root.

I also tried gtf 1366 768 60
and it returned :
# 1368x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 85.86 MHz
Modeline "1368x768_60.00" 85.86 1368 1440 1584 1800 768 769 772 795 -Hsync +Vsync

EDIT: Great, now ctrl alt F1 QUIT WORKING wtf is wrong with this installation. I'm going to try to reinstall off a different disc and see if it works (although i doubt it, it took 11 tries to even get something bootable)

ANOTHER EDIT: OK, got it reinstalled, but its doing the same thing.
xrandr gives me 'Can't open display' and nothing else I have tried has been remotely helpful. I am able to get to xorg.conf now, so exactly what should I add?

Last edited by foothead; 11-30-2009 at 11:44 PM.
 
Old 12-01-2009, 12:26 AM   #4
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Ok, just to confirm that I understand you current situation. You installed Debian stable (Lenny) and when x starts your monitor complains that the refresh rate is too high, X exits, dropping you into a console?

If the above is correct you should be able to specifically tell X what refresh rate to use by reconfiguring the xserver-xorg package. To do this please run the following command:
Code:
dpkg-reconfigure -plow xserver-xorg
If it asks you questions that you don't know the answer to, just leave them blank (or whatever the default is).


Quote:
xrandr gives me 'Can't open display'
As far as I know xrandr will only work within an x session.

Evo2.
 
Old 12-01-2009, 08:40 PM   #5
Hern_28
Member
 
Registered: Mar 2007
Location: North Carolina
Distribution: Slackware 12.0, Gentoo, LFS, Debian, Kubuntu.
Posts: 906

Rep: Reputation: 38
Same Problem.

I had to add the bolded section to my monitor section in /etc/X11/xorg.conf. I got the sync rates off the box my monitor came in an you could try getting the ones for yours and entering them.:

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0

Option "DPMS"
EndSection

Hope that helps.

Last edited by Hern_28; 12-01-2009 at 08:42 PM. Reason: Added a spce to make it easier to read
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] refresh rate too high on debian lenny w/ kde 3.5 on ati radeon hd 4850 mf93 Linux - Software 5 02-07-2010 04:04 PM
Debian refresh rate misreported geraldkelly Linux - Hardware 3 09-19-2005 05:29 PM
9.2 pro high horizontal refresh rate gives black screen w00t_oh_noes SUSE / openSUSE 0 12-03-2004 02:37 PM
How can I set high monitor refresh rate in Mandrake? Dimm0 Linux - Hardware 0 11-03-2004 03:08 PM
refresh rate is to high ethanlindsey Linux - Hardware 1 09-23-2004 07:15 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration