LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-30-2015, 04:23 PM   #16
Lagamorph
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Original Poster
Rep: Reputation: 0

Ok, here's my xorg.0.log file,

http://paste.debian.net/189313


And the results of my dpkg -l | grep -i kde command,

http://paste.debian.net/189314
 
Old 05-30-2015, 04:35 PM   #17
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 284Reputation: 284Reputation: 284
I think you just need an xorg configuration file for your fglrx driver.
https://wiki.debian.org/ATIProprietary#configure
 
Old 05-30-2015, 04:48 PM   #18
Amarildo
Member
 
Registered: Jun 2014
Posts: 176

Rep: Reputation: Disabled
Quote:
Originally Posted by Head_on_a_Stick View Post
I think you just need an xorg configuration file for your fglrx driver.
https://wiki.debian.org/ATIProprietary#configure
If the OP doesn't understand the terminology too well, there's always a simpler way:

Code:
sudo aticonfig --initial
will create and properly configure your display
 
Old 05-30-2015, 04:48 PM   #19
Lagamorph
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Original Poster
Rep: Reputation: 0
I have a file named xorg.conf file at /etc/X11, the contents can be seen below,

http://paste.debian.net/189359


I just ran this,
Code:
sudo aticonfig --initial
and then did a reboot, but unfortunately still booting to the command line.

Last edited by Lagamorph; 05-30-2015 at 04:50 PM.
 
Old 05-30-2015, 04:55 PM   #20
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 284Reputation: 284Reputation: 284
Quote:
Originally Posted by Lagamorph View Post
I have a file named xorg.conf file at /etc/X11, the contents can be seen below,

http://paste.debian.net/189359


I just ran this,
Code:
sudo aticonfig --initial
and then did a reboot, but unfortunately still booting to the command line.
I would recommend (re)moving that file and creating a new configuration file by using the method outlined in my link above.
 
Old 05-30-2015, 04:59 PM   #21
Lagamorph
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Original Poster
Rep: Reputation: 0
Ok, removed the xorg.conf files and re-ran the command then did another reboot, but still booting to command line sadly.
 
Old 05-30-2015, 05:07 PM   #22
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 284Reputation: 284Reputation: 284
Quote:
Originally Posted by Lagamorph View Post
re-ran the command
Which command?

I don't think `aticonfig` is working for your system.

You should try the two commands from my link (after removing any other xorg configuration files on your system):
Code:
# mkdir /etc/X11/xorg.conf.d
# echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "fglrx"\nEndSection' > /etc/X11/xorg.conf.d/20-fglrx.conf
 
Old 05-30-2015, 05:26 PM   #23
Lagamorph
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Original Poster
Rep: Reputation: 0
Ok, just tried this,
Code:
# mkdir /etc/X11/xorg.conf.d
# echo -e 'Section "Device"\n\tIdentifier "My GPU"\n\tDriver "fglrx"\nEndSection' > /etc/X11/xorg.conf.d/20-fglrx.conf
That's created the 20-fglrx.conf file, though no xorg.conf file. I ran a reboot after running those two commands, but still booting into Command line only mode.

Am I supposed to run,
Code:
sudo aticonfig --initial
After running that and then reboot again?
 
Old 05-30-2015, 05:40 PM   #24
Amarildo
Member
 
Registered: Jun 2014
Posts: 176

Rep: Reputation: Disabled
Your system may have many left-over pieces from the drivers you installed manually. Not to mention there could be problems in the Kernel because you installed them that way.

IMO it's way easier/faster to just use a LiveCD to backup your data and then re-install Debian and then the drivers as I described on the previous page, as manually installing them (from the .run file) can lead to lots of problems if the user doesn't know how to maintain the Kernel/drivers and/or how to fix things if something goes wrong.
Quote:
Am I supposed to run,
Code:

sudo aticonfig --initial

After running that and then reboot again?
Do you still have the ATI driver installed? Which one? Did you remove the driver you manually installed?

Quote:
That's created the 20-fglrx.conf file, though no xorg.conf file
That's OK.
 
Old 05-30-2015, 05:40 PM   #25
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 284Reputation: 284Reputation: 284
Quote:
Originally Posted by Lagamorph View Post
Am I supposed to run,
Code:
sudo aticonfig --initial
After running that and then reboot again?
No, I don't think that would help.

Quote:
Originally Posted by Lagamorph View Post
I did some more Googling, ran some commands and did some apt-get installs (though sadly I can't recall exactly what they were)
You must have b0rked your system doing this.

Post the output of:
Code:
apt-cache policy
 
Old 05-30-2015, 05:45 PM   #26
Lagamorph
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Original Poster
Rep: Reputation: 0
I think you're probably right and I have borked it

Here's the results of the apt-cache policy,

http://paste.debian.net/189421



I may just chalk this one up as a lesson learned and reinstall, then follow Amarildo's steps to get setup as I want. Then be sure to take a backup image I can restore from incase of future...'lessons'


For what it's worth I installed by burning the main installation disc to a USB pen rather than burning DVDs.
One thing I have noticed is the occasional popup when I started up (when I could get into GUI mode) asking for the CD-ROM. Any way I can get rid of that when I do reinstall?

Last edited by Lagamorph; 05-30-2015 at 05:49 PM.
 
Old 05-30-2015, 05:58 PM   #27
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 284Reputation: 284Reputation: 284
Quote:
Originally Posted by Lagamorph
Code:
500 http://repo.steampowered.com/steam/ precise/steam i386 Packages
     origin repo.steampowered.com
 500 http://repo.steampowered.com/steam/ precise/steam amd64 Packages
     origin repo.steampowered.com
What the hell are these?

When you re-install, follow this guide:
https://wiki.debian.org/Steam
 
Old 05-30-2015, 06:00 PM   #28
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 284Reputation: 284Reputation: 284
Quote:
Originally Posted by Lagamorph View Post
One thing I have noticed is the occasional popup when I started up (when I could get into GUI mode) asking for the CD-ROM. Any way I can get rid of that when I do reinstall?
Edit the file at /etc/apt/sources.list and remove the lines relating to the CD-ROM
 
Old 05-30-2015, 06:00 PM   #29
Lagamorph
LQ Newbie
 
Registered: Oct 2006
Posts: 20

Original Poster
Rep: Reputation: 0
I installed Steam using a guide I found on the Steam forums, which involved downloading and running a steam.deb file, I believe those were likely added by that package.


And thanks! Thank you everyone who's contributed! Despite not quite getting there, I do feel I've learned a few things. And that's what really matters right? No harm done and I learned something along the way.
 
Old 05-30-2015, 06:02 PM   #30
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 284Reputation: 284Reputation: 284
Quote:
Originally Posted by Lagamorph View Post
I installed Steam using a guide I found on the Steam forums, which involved downloading and running a steam.deb file, I believe those were likely added by that package.
That is entirely unnecessary in Debian jessie -- I have it working perfectly in my jessie systems by following the Debian wiki guide I have linked above.
 
  


Reply

Tags
boot, debian, kde


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB booting into command line Username2 Gentoo 4 10-14-2011 06:08 AM
Booting Into Command Line ChrisWho Linux - General 19 04-14-2010 02:29 AM
Booting to command line? Barrien Linux - Newbie 2 09-04-2009 10:45 AM
Command Line appears after booting khadija Linux - Newbie 6 07-28-2008 08:16 AM
keeps booting Command line Rahk Linux - General 7 07-17-2008 11:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration