LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-07-2009, 07:02 PM   #1
AncientBrit
LQ Newbie
 
Registered: Apr 2009
Location: Los Angeles
Distribution: Debian Lenny (for now)
Posts: 5

Rep: Reputation: 0
Debian login window resolution is too high - how to reduce?


This is something of a n00b problem and it's one that I figure that I should, with 30 years computing experience under my belt, be able to resolve myself, but not so far.

I'm running Debian 5.0 (Lenny) with Gnome on a multiboot system (other OS is Widnose XP; default is Debian).

While I can manipulate the screen resolution OK once the desktop appears *after* login (using System > Preferences > Screen Resolution), my problem is that after selecting (or defaulting to) Debian from the boot menu and waiting for the login screen to appear, when it does appear it is almost unreadable.

The resolution is something odd like 1920 x 1080 and the dialog text is really miniscule (it's as if the smallest font available is being compressed still further on the vertical axis according to some algorithm - but it's probably just an incorrect vertical resolution setting somewhere).

While there are a few options available at the login screen (Language, Session, Actions) there's nothing available to bring up any interface to permanently change the resolution at this point.

(I should point out that my setup is a little unusual in that my display screen is 48" and I'm forced to sit about 10 feet away from it, so 1024 x 768 would be preferable ).

I've searched around and found that most people want to increase rather than reduce their resolution once they've got the desktop; so far I haven't found anyone reporting my particular problem (closest is having a login display that's either blank or scrambled).

I looked at modifying the boot-time option to include an explicitly lower vga setting at the point that I choose (or default to) Debian.

The apropriate entry in /boot/grub/menu.lst is, as far as I can see:

title Debian GNU/Linux, kernel 2.6.26-1-686
root (hd0,1)
kernel /boot/vmlinuz-2.6.26-1-686 root=/dev/hda2 ro quiet
initrd /boot/initrd.img-2.6.26-1-686

and I added a vga=773 to the end of the kernel line after "quiet" (based on a suggestion found elsewhere here), which, because the value was invalid, triggered a useful interaction that gave me a list of the available valid modes, some of which I tried, but to no avail.

All any of the values did was to change the *text* screen resolution prior to the login window, which remained at its very high setting.

Next, I looked at xorg.conf (/etc/X11/) to see whether there was anything helpful in the settings there:

Section "Device"
Identifier "Configured Video Device"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
EndSection

Nothing gave me any clues here (but I might not even be looking at the right file for all I know).

There's probably a bootlog file somewhere that's informative; the system log that I examined (Applications > System Tools > System Log) didn't tell me anything that gave me an Ahah! moment.

So that exhausts my current very limited knowledge of where to look and what to look for. My suspicion is that I may need to recompile the kernel after performing some configuration changes, but that's just a hunch and not based on an intelligent deduction

Grateful for any ideas.

Best,

Peter
 
Old 04-07-2009, 07:14 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
I think in xorg.conf you need
Code:
Section "Screen"
    Identifier    "Default Screen"
    Device        "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
    Monitor        "SAMTRON 55V"
    DefaultDepth    24
    SubSection "Display"
        Modes        "1024x768" 
        Virtual      1024 768
    EndSubSection
EndSection
You may also need to modify /etc/gdm/gdm.conf to set the position of the login window
Code:
SetPosition=true
PositionX=130
PositionY=110
 
Old 04-08-2009, 05:59 PM   #3
AncientBrit
LQ Newbie
 
Registered: Apr 2009
Location: Los Angeles
Distribution: Debian Lenny (for now)
Posts: 5

Original Poster
Rep: Reputation: 0
Debian login window resolution is too high - how to reduce? SOLVED

Hi plj

Thanks for your reply - it had me going on a bit of a wild goose chase, thanks to the way that Google interpreted the red text in your sample code (it surrounded the red code with asterisks, which, like a true n00b, I faithfully copied and pasted into xorg.conf, thereby locking myself out of the GUI on reboot, as it crashed the X server before I could even log in <oops>

Luckily I recovered OK from that (logged in to the VT as root and copied a prior safety backup <phew> over the incorrect xorg.conf - thank goodness for paranoia )

The interesting thing (aside from the fact that when I did finally get the code in there correctly, the boot process calmly ignored the new settings and proceeded to give me the usual ultra-hi-res login screen) is that I found a solution as a result of trawling through the man pages for Xorg.

It turns out that once you get to the login screen, certain Ctrl-Alt functions become available, and one of them is Ctrl-Alt-Keypad-Minus, which conveniently cycles round (along with its forward-cycling counterpart Ctrl-Alt-Keypad-Plus) the available resolutions (including a few that the monitor didn't like, but that's no biggie - you just keep banging away on the keycombo until you get a decently low resolution that's workable ).

It's more of a zoom function, really, by this point: the menu items (Language, Session, Actions) aren't visible but that doesn't really matter since the key item (login dialog) is smack in the middle of the screen anyway.

So thanks very much, even though it didn't work as planned - thanks to trying to work out what the section contents should be I ended up moving through man pages for xorg.conf and Xorg and found a very simple workaround, and that's all that I needed at this point.

Later I'll find out what should be put into xorg.conf to get it to function as needed during login.

Best,

Peter
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Login Window Failed to start in Debian raghuveerbabu Linux - Newbie 5 08-22-2007 05:26 AM
Debian to reduce the number of supported platform ket Linux - News 2 01-06-2006 11:20 PM
Can't get high resolution in Slackware Algernon Linux - Newbie 7 08-06-2004 03:24 PM
Set resolution too high, can't even login on RH9 fireman949 Linux - Newbie 8 12-13-2003 05:18 PM
High Resolution Timers snoopy42 Linux - General 2 12-10-2002 06:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration