LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-11-2007, 04:18 PM   #1
Dryzell
LQ Newbie
 
Registered: Nov 2007
Posts: 2

Rep: Reputation: 0
Debian install not detecting nic


So i'm trying to install Debian 4.0r1. I've tried the netinst and full cd and the install will not auto detect that i have a network card. It then pops up and asks me to choose the driver for the card. After i choose the driver it just goes right back to that same page and asks me to choose the driver again. I've tried a few different nics and it does the same on each. I've tried the onboard card, which is a realtek. Then disabled the on board and tried a few different pci cards in different slots including a realtek 8139C, 3 different revisions of 3com 3c905, and a netgear FA310TX. In the install it has each of the cards on the list and i went and downloaded a different 3c905 driver and each time it goes back to the No nic detected choose card from list.


Should i just install a base system and get it to work there or is there a easy way to get it to work in the install.

Thanks.
 
Old 11-11-2007, 05:12 PM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: SlackWare > Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie stretch buster
Posts: 1,621

Rep: Reputation: 98
Hya,

I am sure that you already have checked network connection. You already ruled out possible irq conflict.

There are two realtek drivers 8139too and 8139cp. Did you try both?

Your solution is one way. Another way is to install some other version of Debian and upgrade.

Happy Penguins!
 
Old 11-15-2007, 09:20 PM   #3
Dryzell
LQ Newbie
 
Registered: Nov 2007
Posts: 2

Original Poster
Rep: Reputation: 0
It worked fine in the base system. I went and downloaded everything else i wanted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NIC recognized in debian net install but not after install Cycle Debian 7 12-23-2005 08:52 PM
help me install a PCMCIA NIC in Debian 3.0 bobby98989 Debian 12 08-09-2004 04:34 PM
not detecting eth0 on new debian install allasso Linux - Newbie 11 10-24-2003 09:39 AM
RH 8.0 not detecting onboard nic sugaman Linux - Hardware 5 09-16-2003 08:58 PM
Debian Sarge install with PCMCIA NIC peterthevicar Debian 0 07-13-2003 09:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration