Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 05-05-2011, 10:09 AM   #1
Weapon S
Registered: May 2011
Location: Netherlands
Distribution: Debian, Archlinux
Posts: 259
Blog Entries: 2

Rep: Reputation: 49
Debian: I "have mail" ?! What does that mean?

I typed in a XTerm in IceWM(knowing I don't have permissions):
dpkg-reconfigure keyboard-configuration
And got:
You have email in /var/mail/username
#1 I can't access that folder with these permissions. Why would it place it in such a folder?! What is in this file?
#2 What part of the system is responsible for this/ where do I turn this off?
Any help appreciated.
Old 05-05-2011, 11:01 AM   #2
Senior Member
Registered: Sep 2010
Location: Wales, UK
Distribution: Arch
Posts: 1,632
Blog Entries: 3

Rep: Reputation: 346Reputation: 346Reputation: 346Reputation: 346
Try typing 'mail', that should open up the mail programme and show you the message. And I know they send mail to root (if it's configured to do so) when you try to become root using the 'sudo' command but aren't authorised to do so. So perhaps it's just a notification that a user is doing something they don't have permission to do (ie. using the command you typed)
1 members found this post helpful.
Old 05-05-2011, 12:02 PM   #3
Weapon S
Registered: May 2011
Location: Netherlands
Distribution: Debian, Archlinux
Posts: 259

Original Poster
Blog Entries: 2

Rep: Reputation: 49
So there is this program called 'mail'? I see. Indeed it seems to be a system message. Also actually I did have permissions to access the file (I just thought ~ was the top directory XD ). Still, I'd rather disable this behaviour. The info says mails can be 'undeleted': I'd rather not have something silly like this bogging up my HD eventually.
Old 05-05-2011, 02:11 PM   #4
Senior Member
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
If you think about it, you'll see there's nothing silly about it, it's just how you see it.
Old 05-06-2011, 05:21 PM   #5
Registered: Mar 2005
Location: Ohio
Distribution: Freebsd and Ubuntu
Posts: 69

Rep: Reputation: 17
Different distros (and bsd) have their own reasons to send mail. Freebsd I know sends mail if you run an incorrect command in cron.

It's just to detail the error message. You can suppress this method, but I honestly don't remember how. I've never personally ran debian, so I don't know the specifics for it.

As a guess... since you got it through dpkg-configure, it might be in one of the apt-get or package configuration files. Do a grep in /etc/ for 'mail' or something and see what sends mails automatically and then simply comment them out.

Although there is always reasons for wanting the mail. You never know when dpkg might go nuts and you don't know why and the detail would be in the mail. My suggestion is just goto /var/mail/yourusername/ and just wipe it every so often. The mails are quite tiny in size.

Last edited by jake3988; 05-06-2011 at 05:26 PM.
Old 05-07-2011, 06:00 AM   #6
Weapon S
Registered: May 2011
Location: Netherlands
Distribution: Debian, Archlinux
Posts: 259

Original Poster
Blog Entries: 2

Rep: Reputation: 49
Ok. Thanks for all the replies. Starts to sound a bit logical. However, as long as I haven't figured out how to disable it or whether I want to disable it, I won't mark this thread as [SOLVED] (Wouldn't even know how ;D )
Old 05-07-2011, 06:32 PM   #7
Registered: May 2009
Location: Detroit, MI
Distribution: Debian (LXDE), Fedora (Sugar), PuppyLinux (JWM)
Posts: 69

Rep: Reputation: 17
You'll need to click the link that says "Mark this thread as solved" near the top of the page within the sentence:

Please Mark this thread as solved if you feel a solution has been provided.

You opened it so you get to decide when its solved.
Old 05-07-2011, 10:45 PM   #8
LQ Guru
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, and whatever VMs I happen to be playing with
Posts: 14,276
Blog Entries: 24

Rep: Reputation: 3896Reputation: 3896Reputation: 3896Reputation: 3896Reputation: 3896Reputation: 3896Reputation: 3896Reputation: 3896Reputation: 3896Reputation: 3896Reputation: 3896
The messages are probably originating from a program called sendmail, which is part of Linux (mail was built into Linux from the git-go).

You can disable sendmail from starting up, but it's better to let it do its thing and read the messages from time to time. They might notify you of something you need to know.

See man mail and man sendmail for more information.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Perl: how to save an e-mail attachment on disk keeping the "&" character (no "%26"!!) d1s4st3r Programming 5 09-29-2010 10:30 PM
Command "mail" returns "panic: temporary file seek" kenneho Linux - Software 5 12-23-2008 04:27 AM
How might I restore kmail folders/mail/settings from a "badly" saved "home"? deh6 Linux - Software 5 03-08-2008 10:25 PM
Ntfs-Fuse copy error Debian "Sid" / Ubuntu "6.06" animefriik Linux - General 0 10-06-2006 10:28 AM
Debian Boot Up Problem - stuck at "BR" & "I" jc70417 Debian 2 08-30-2005 05:36 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:30 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration