LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-01-2005, 11:54 AM   #1
kaens
LQ Newbie
 
Registered: Feb 2005
Posts: 19

Rep: Reputation: 0
Debian, dial-up internet connectivity - almost.


Alright....to start this off, I did a bunch of searching on this site to see if anyone else had already posted a solution to this, so if I missed it, just point me to the thread and slap me with a "use better search criteria stick."

I can't connect to the internet on my linux (debian) box. Or rather I almost can. wvdial does not work at all....here is it's output:

Quote:
--> WvDial: Internet dialer version 1.53
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT6220886
--> Waiting for carrier.
ATDT6220886
CONNECT 115200
**************************************************************************
WARNING: If you are not authorized to access this system, disconnect now!
YOU SHOULD HAVE NO EXPECTATION OF PRIVACY.
By continuing, you consent to your keystrokes
and data content being monitored.
Access is restricted to authorized users only.
Unauthorized access is a violation of state and federal,
civil and criminal laws. Violations will be prosecuted to
the fullest extent of the law with no exceptions.
**************************************************************************
User Access Verification
Username:
--> Carrier detected. Waiting for prompt.
--> Connected, but carrier signal lost! Retrying...
--> Sending: ATDT6220886
--> Waiting for carrier.
Username:
--> Carrier detected. Waiting for prompt.
--> Connected, but carrier signal lost! Retrying...
--> Sending: ATDT6220886
--> Waiting for carrier.
Username:
Username:
Username:
--> Disconnecting at Tue Feb 1 12:22:09 2005
Caught signal #2! Attempting to exit gracefully...
It will sit there and repeat that over and over until I exit it. Perhaps I should update wvdial....the version I have is most likely out of date.

Anyhow, since that did not work, I tried pon. The closest I could get to connectivity was using CHAP, so I assume that is what my ISP (ntelos) is using. Here is what happens with pon:

Quote:
Feb 1 12:22:32 debian pppd[474]: pppd 2.4.1 started by root, uid 0
Feb 1 12:22:33 debian chat[475]: abort on (BUSY)
Feb 1 12:22:33 debian chat[475]: abort on (NO CARRIER)
Feb 1 12:22:33 debian chat[475]: abort on (VOICE)
Feb 1 12:22:33 debian chat[475]: abort on (NO DIALTONE)
Feb 1 12:22:33 debian chat[475]: abort on (NO DIAL TONE)
Feb 1 12:22:33 debian chat[475]: abort on (NO ANSWER)
Feb 1 12:22:33 debian chat[475]: abort on (DELAYED)
Feb 1 12:22:33 debian chat[475]: send (ATZ^M)
Feb 1 12:22:33 debian chat[475]: expect (OK)
Feb 1 12:22:33 debian chat[475]: ATZ^M^M
Feb 1 12:22:33 debian chat[475]: OK
Feb 1 12:22:33 debian chat[475]: -- got it
Feb 1 12:22:33 debian chat[475]: send (ATDT6220886^M)
Feb 1 12:22:33 debian chat[475]: expect (CONNECT)
Feb 1 12:22:33 debian chat[475]: ^M
Feb 1 12:22:58 debian chat[475]: ATDT6220886^M^M
Feb 1 12:22:58 debian chat[475]: CONNECT
Feb 1 12:22:58 debian chat[475]: -- got it
Feb 1 12:22:58 debian chat[475]: send (^M)
Feb 1 12:22:58 debian chat[475]: expect (sername
Feb 1 12:22:58 debian chat[475]: 115200^M
Feb 1 12:22:58 debian chat[475]: ^M
Feb 1 12:22:58 debian chat[475]: **************************************************************************^M
Feb 1 12:22:58 debian chat[475]: WARNING: If you are not authorized to access this system, disconnect now!^M
Feb 1 12:22:58 debian chat[475]: ^M
Feb 1 12:22:58 debian chat[475]: YOU SHOULD HAVE NO EXPECTATION OF PRIVACY.^M
Feb 1 12:22:58 debian chat[475]: ^M
Feb 1 12:22:58 debian chat[475]: By continuing, you consent to your keystrokes^M
Feb 1 12:22:58 debian chat[475]: and data content being monitored.^M
Feb 1 12:22:58 debian chat[475]: Access is restricted to authorized users only.^M
Feb 1 12:22:58 debian chat[475]: Unauthorized access is a violation of state and federal,^M
Feb 1 12:22:58 debian chat[475]: civil and criminal laws. Violations will be prosecuted to^M
Feb 1 12:22:58 debian chat[475]: the fullest extent of the law with no exceptions.^M
Feb 1 12:22:58 debian chat[475]: ^M
Feb 1 12:22:58 debian chat[475]: **************************************************************************^M
Feb 1 12:22:58 debian chat[475]: ^M
Feb 1 12:22:58 debian chat[475]: ^M
Feb 1 12:22:58 debian chat[475]: User Access Verification^M
Feb 1 12:22:58 debian chat[475]: ^M
Feb 1 12:22:58 debian chat[475]: Username:
Feb 1 12:22:58 debian chat[475]: -- got it
Feb 1 12:22:58 debian chat[475]: send (*******^M)
Feb 1 12:22:58 debian chat[475]: expect (assword
Feb 1 12:22:58 debian chat[475]: ^M
Feb 1 12:22:58 debian chat[475]: Username: *******^M
Feb 1 12:22:58 debian chat[475]: Password:
Feb 1 12:22:58 debian chat[475]: -- got it
Feb 1 12:22:58 debian chat[475]: send (??????)
Feb 1 12:22:58 debian chat[475]: send (\d)
Feb 1 12:22:59 debian pppd[474]: Serial connection established.
Feb 1 12:22:59 debian pppd[474]: using channel 3
Feb 1 12:22:59 debian pppd[474]: Using interface ppp0
Feb 1 12:22:59 debian pppd[474]: Connect: ppp0 <--> /dev/ttyS0
Feb 1 12:23:00 debian pppd[474]: sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xbc0dc6fe> <pcomp> <accomp>]
Feb 1 12:23:01 debian pppd[474]: rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xbc0dc6fe> <pcomp> <accomp>]
Feb 1 12:23:01 debian pppd[474]: rcvd [LCP ConfReq id=0xb5 <asyncmap 0xa0000> <magic 0xfb6de6c8> <pcomp> <accomp>]
Feb 1 12:23:01 debian pppd[474]: sent [LCP ConfAck id=0xb5 <asyncmap 0xa0000> <magic 0xfb6de6c8> <pcomp> <accomp>]
Feb 1 12:23:01 debian pppd[474]: sent [LCP EchoReq id=0x0 magic=0xbc0dc6fe]
Feb 1 12:23:01 debian pppd[474]: sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <compress VJ 0f 01> <ms-dns1 0.0.0.0> <ms-dns3 0.0.0.0>]
Feb 1 12:23:01 debian pppd[474]: sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
Feb 1 12:23:01 debian pppd[474]: rcvd [LCP EchoRep id=0x0 magic=0xfb6de6c8]
Feb 1 12:23:01 debian pppd[474]: rcvd [IPCP ConfReq id=0x9f <compress VJ 0f 00> <addr 216.12.96.200>]
Feb 1 12:23:01 debian pppd[474]: sent [IPCP ConfAck id=0x9f <compress VJ 0f 00> <addr 216.12.96.200>]
Feb 1 12:23:01 debian pppd[474]: rcvd [IPCP ConfReq id=0xa0 <compress VJ 0f 00> <addr 216.12.96.200>]
Feb 1 12:23:01 debian pppd[474]: sent [IPCP ConfAck id=0xa0 <compress VJ 0f 00> <addr 216.12.96.200>]
Feb 1 12:23:01 debian pppd[474]: rcvd [LCP ProtRej id=0xb6 80 fd 01 01 00 0f 1a 04 78 00 18 04 78 00 15 03 2f]
Feb 1 12:23:01 debian pppd[474]: rcvd [IPCP ConfNak id=0x1 <addr 216.12.114.30> <ms-dns1 216.12.23.231> <ms-dns3 216.12.0.20>]
Feb 1 12:23:01 debian pppd[474]: sent [IPCP ConfReq id=0x2 <addr 216.12.114.30> <compress VJ 0f 01> <ms-dns1 216.12.23.231> <ms-dns3 216.12.0.20>]
Feb 1 12:23:01 debian pppd[474]: rcvd [IPCP ConfAck id=0x2 <addr 216.12.114.30> <compress VJ 0f 01> <ms-dns1 216.12.23.231> <ms-dns3 216.12.0.20>]
Feb 1 12:23:01 debian pppd[474]: not replacing existing default route to eth0 [192.168.1.2]
Feb 1 12:23:01 debian pppd[474]: Cannot determine ethernet address for proxy ARP

Feb 1 12:23:01 debian pppd[474]: local IP address 216.12.114.30
Feb 1 12:23:01 debian pppd[474]: remote IP address 216.12.96.200
Feb 1 12:23:01 debian pppd[474]: primary DNS address 216.12.23.231
Feb 1 12:23:01 debian pppd[474]: secondary DNS address 216.12.0.20
Feb 1 12:23:01 debian pppd[474]: Script /etc/ppp/ip-up started (pid 478)
Feb 1 12:23:01 debian pppd[474]: Script /etc/ppp/ip-up finished (pid 478), status = 0x1
Feb 1 12:23:31 debian pppd[474]: sent [LCP EchoReq id=0x1 magic=0xbc0dc6fe]
Feb 1 12:23:31 debian pppd[474]: rcvd [LCP EchoRep id=0x1 magic=0xfb6de6c8]

Feb 1 12:23:37 debian pppd[474]: Terminating on signal 15.
Feb 1 12:23:37 debian pppd[474]: Script /etc/ppp/ip-down started (pid 515)
Feb 1 12:23:37 debian pppd[474]: sent [LCP TermReq id=0x2 "User request"]
Feb 1 12:23:37 debian pppd[474]: Script /etc/ppp/ip-down finished (pid 515), status = 0x1
Feb 1 12:23:37 debian pppd[474]: rcvd [LCP TermAck id=0x2]
Feb 1 12:23:37 debian pppd[474]: Connection terminated.
Feb 1 12:23:37 debian pppd[474]: Connect time 0.7 minutes.
Feb 1 12:23:37 debian pppd[474]: Sent 103 bytes, received 82 bytes.
Feb 1 12:23:38 debian pppd[474]: Exit.
I highlighted the parts that stuck out to me. It will sit there and do the sent [LCP.... rcvd LCP.... forever. I can ping the remote address fine, but I can not ping anything else. (Well, besides myself but duh.) Can't ping the DNS servers, web pages based on IP, nothing. So I figure something funky must be wrong on my end, since the connection works fine with windows, and the modem works (its a generic external serial modem). Perhaps it is related to the "cannot determine ethernet....."

Anyhow, any help is appreciated....if you need more info, just tell me.
 
Old 02-01-2005, 01:49 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,571

Rep: Reputation: 180Reputation: 180
What do you have in /etc/ppp/options ? Please copy only the option, not the whole file (most of it are comments).
 
Old 02-01-2005, 02:04 PM   #3
kaens
LQ Newbie
 
Registered: Feb 2005
Posts: 19

Original Poster
Rep: Reputation: 0
here are the options that were not commented out:

asyncmap 0
auth
crtscts
lock
hide-password
modem
proxyarp
lcp-echo-interval 30
lcp-echo-failure 4
noipx

should I comment out proxyarp?
 
Old 02-01-2005, 07:47 PM   #4
kaens
LQ Newbie
 
Registered: Feb 2005
Posts: 19

Original Poster
Rep: Reputation: 0
I tried commenting out proxyarp and it did the exact same thing....no change. Anybody have an idea as to what is wrong here?
 
Old 02-01-2005, 11:59 PM   #5
kaens
LQ Newbie
 
Registered: Feb 2005
Posts: 19

Original Poster
Rep: Reputation: 0
Alright I figured it out. So if anyone else has the same problem - here is the solution that I found.
The reason that I could not ping past the PPP server was because my default route was wrong - I was sending packets to eth0, which isn't connected to anything. All I had to do to fix this was issue the command route del default. Now it works fine! Posting this from lynx in Debian. Hooray for me!
 
Old 02-12-2005, 09:29 AM   #6
michlham
LQ Newbie
 
Registered: Dec 2003
Location: Currently Alabama, but not for long.
Distribution: Mandrake 10.0
Posts: 4

Rep: Reputation: 0
Can't get past the ppp server...

I have been having pretty much the same problem, but changing the default route has not effect. My problem did not start until I started trying to use my wireless at the same time. Now even though I have removed my wireless, I still cannot get past the ppp server.

The routing table before making changes.

route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
1.1.21.2 * 255.255.255.255 UH 0 0 0 ppp0
192.168.1.0 * 255.255.255.0 U 0 0 0 wlan0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 192.168.1.1 0.0.0.0 UG 0 0 0 wlan0

The logs before the change.

Feb 9 23:51:37 fortune pppd[8916]: pppd 2.4.1 started by michael, uid 501
Feb 9 23:51:37 fortune pppd[8916]: Using interface ppp0
Feb 9 23:51:37 fortune pppd[8916]: Connect: ppp0 <--> /dev/ttySHSF0
Feb 9 23:51:38 fortune pppd[8916]: Remote message: ^@
Feb 9 23:51:38 fortune pppd[8916]: Couldn't set pass-filter in kernel: Invalid argument
Feb 9 23:51:38 fortune pppd[8916]: not replacing existing default route to wlan0 [192.168.1.1]
Feb 9 23:51:38 fortune pppd[8916]: local IP address 64.63.229.236
Feb 9 23:51:38 fortune pppd[8916]: remote IP address 1.1.21.2
Feb 9 23:51:38 fortune pppd[8916]: primary DNS address 64.63.229.134
Feb 9 23:51:38 fortune pppd[8916]: secondary DNS address 64.63.212.3


The routing table after changing the default gateway.

route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
1.1.21.2 * 255.255.255.255 UH 0 0 0 ppp0
192.168.1.0 * 255.255.255.0 U 0 0 0 wlan0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 1.1.21.2 0.0.0.0 UG 0 0 0 ppp0

The logs after starting pppd after changing the routing table.

Feb 9 23:55:55 fortune pppd[9049]: pppd 2.4.1 started by michael, uid 501
Feb 9 23:55:55 fortune pppd[9049]: Using interface ppp0
Feb 9 23:55:55 fortune pppd[9049]: Connect: ppp0 <--> /dev/ttySHSF0
Feb 9 23:55:56 fortune pppd[9049]: Remote message: ^@
Feb 9 23:55:56 fortune pppd[9049]: Couldn't set pass-filter in kernel: Invalid argument
Feb 9 23:55:56 fortune pppd[9049]: local IP address 64.63.229.239
Feb 9 23:55:56 fortune pppd[9049]: remote IP address 1.1.21.2
Feb 9 23:55:56 fortune pppd[9049]: primary DNS address 64.63.229.134
Feb 9 23:55:56 fortune pppd[9049]: secondary DNS address 64.63.212.3

Note the only line omitted was the one regarding not replacing the default gateway.

If someone has any ideas, I would appreciate it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
debian on dial-up-- no internet bluesky2005 Linux - Networking 5 03-27-2005 03:19 PM
No Internet Connectivity laltupi Linux - Networking 1 07-19-2004 10:34 AM
Internet Connectivity is a NO-GO Help Please!! ClericPreston Linux - Newbie 1 06-04-2004 07:36 PM
Internet/Network connectivity unixops72 Linux - Networking 4 01-09-2004 08:35 PM
SUSE 8.0 and Internet connectivity mastahnke Linux - Networking 2 03-06-2003 09:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration